Bug 49850 - povray creates PNG files with too many IDATs
povray creates PNG files with too many IDATs
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: povray (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 12:06 EDT by David Nečas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 10:28:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2001-07-24 12:06:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
All PNG files povray creates (as rendered output images) seems to have some
extra IDAT chunks.

How reproducible:
Always

Steps to Reproduce:
1. Take any scene, for reference, take following scene, let's call it
scene.pov:

  camera { location <0,0,-1> look_at <0,0,0> }
  sphere { <0,0,0> 0.3 pigment { color rgb<1,1,1> } finish { ambient 1 } }

2. run

  $ x-povray +FN +Iscene.pov +Oscene.png

3. try to open scene.png in some program verbose enough about libpng
errors, namely: GIMP, xv, ImageMagick, gqview, or anything else.

	

Actual Results:  The image scene.png is created.  All programs mentioned in
step 3 complain about libpng error. GIMP pops up a dialog saying there are
too many IDATs in the file.

Expected Results:  The image scene.png is created.  It can be opened in
other programs without problems.

Additional info:

I don't have an independent PNG implementation, all the mentioned programs
depend on libpng so, theoretically, it could be a libpng bug too.  However,
it doesn't look so.
Comment 1 Tim Powers 2001-07-24 13:15:43 EDT
This just creates a black background  with a white circle, yes?

Tim
Comment 2 Need Real Name 2001-07-25 12:18:15 EDT
POV-Ray uses the standard libpng to write PNG image files.
Comment 3 David Nečas 2001-07-26 08:45:19 EDT
Yes, it just creates a black background with a white circle.

My original description was not precise.  The problem is not related to IDAT
boundaries, there is simply some extra data.  Because PoV-Ray creates PNGs with
lots of small IDATs, it can sometimes seem there are whole extra IDATs.
Comment 4 Bernhard Rosenkraenzer 2002-02-07 12:16:20 EST
Since powertools has been discontinued, we have no means of fixing this in the next 
release (because it won't be made). 

Note You need to log in before you can comment on or make changes to this bug.