Bug 498514 - hald-addon-input appears to make really difficult shutting down from a desktop session
hald-addon-input appears to make really difficult shutting down from a deskto...
Status: CLOSED DUPLICATE of bug 495326
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-30 16:11 EDT by Michal Jaegermann
Modified: 2009-05-01 16:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-01 16:29:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
a fragment of logs showing tasks after an attempted shutdown (200.88 KB, text/plain)
2009-04-30 16:11 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2009-04-30 16:11:17 EDT
Created attachment 341992 [details]
a fragment of logs showing tasks after an attempted shutdown

Description of problem:

After 'shutdown -h now', or after shutdown from a gdm menu, a system shuts down and powers off as expected.  Unfortunately this is not the case when attempting to use that from a menu on a desktop session.  A procedure is started and later on on text consoles it is possible to find a broadcast message:

The system is going down for halt NOW!

three or four times. A remote login after that is cut off and there is no more local shells available. That is it.  The system sits there and does nothing.
SysRq key, when turned on, is still active and it is possible to force a reboot that way.  Otherwise a power switch is the only remaining option.

With "show-blocked-tasks" from SysRq it looks like that a system sits
in hald-addon-input probably waiting for some event from a kernel.

Attached is everything which was registered in /var/log/messages after
attempted shutdown and when, after a system got catatonic, "show-task-states"
and "show-blocked-tasks" from SysRq was hit.  It is obvious that some output fragments never made to a disk (but that was possible to see only after a reboot).

Version-Release number of selected component (if applicable):

How reproducible:
Most of the times I tried.  Initially I got that every time but when I tried to check if 'nomodeset' in boot parameters makes a difference (it does not appear to be any) a machine shut down as it was supposed to.

It appears that it is harder to repeat that hang with kernel, but not impossible, and with it at least once I got "reboot" when asking for "shutdown".  Some kind of a race between kernels and hal?

Additional info:
Selinux is not involved as on the affected system it is turned off.
Comment 1 Gianluca Cecchi 2009-05-01 07:06:59 EDT
I have the same on my laptop (Dell XPS M1330) but it happens only when I follow these steps:
1) at boot I stop grub and I add "3" to the kernel line so that I boot in runlevel 3 (sometimes when I want to change xorg.conf file)
2) in console mode I run "init 5" and I go in gdm
3) I login and work
4) At the end of my work I Select System -> Shutdown -> shutdown
5) It goes to console mode with the message 
The system is going down for halt NOW!

But it remains there

6) Only if I press the power button of the laptop it goes through the complete shutdown procedure
Comment 2 yunus 2009-05-01 13:00:27 EDT
recently I also have this issue on TravelMate 6291 laptop. I don't remember what package that causes this issue since I always perform full update. This issue really annoys me.

Do not hesitate to request for info from to solve this bug.

Thank you
Comment 3 Bill Nottingham 2009-05-01 16:29:25 EDT

*** This bug has been marked as a duplicate of bug 495326 ***

Note You need to log in before you can comment on or make changes to this bug.