Bug 49852 - Crash after selecting partitions with disk druid
Summary: Crash after selecting partitions with disk druid
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-24 16:19 UTC by Daniel Powell
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 16:17:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Powell 2001-07-24 16:19:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010710

Description of problem:
The installer crashes after selecting partitions with disk druid. Traceback
attached.

How reproducible:
Always

Steps to Reproduce:
1. Run GUI installer
2. Choose reiserfs or EXT3 as file system
3. Click next after assigning partitions
CRash!


Actual Results:  Anaconda Crashed
Saved Trace
Rebooted

Expected Results:  Installer should have continued to the next screen

Additional info:

Traceback (innermost last):
File "/usr/bin/anaconda", line 580, in ?
intf.run(id, dispatch, configFileData)
File "/usr/lib/anaconda/gui.py", line 340, in run
self.icw.run (self.runres, configFileData)
File "/usr/lib/anaconda/gui.py", line 765, in run
mainloop ()
File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
_gtk.gtk_main()
File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
ret = apply(self.func, a)
File "/usr/lib/anaconda/gui.py", line 392, in nextClicked
self.setScreen ()
File "/usr/lib/anaconda/gui.py", line 513, in setScreen
new_screen = apply(self.currentWindow.getScreen, args)
File "/usr/lib/anaconda/iw/bootloader_gui.py", line 488, in getScreen
self.imageList.append(row)
File "/usr/lib/python1.5/site-packages/gtk.py", line 1182, in append
return _gtk.gtk_clist_append(self._o, values)
TypeError: sequence item not a string

Local variables in innermost frame:
self: <gtk.GtkCList instance at 857a4c0>
values: ('', '/dev/hda2', 'ntfs', None)

Comment 1 Glen Foster 2001-07-24 20:43:14 UTC
This defect is considered MUST-FIX for Fairfax.

Comment 2 Michael Fulbright 2001-07-25 16:08:04 UTC
We cannot reproduce this defect report.

Please give detailed instructions on the steps you took to partition the system.

Comment 3 Michael Fulbright 2001-07-25 16:17:28 UTC
Meanwhile we will try again with a system with NT installed on NTFS (is this
your situation?).

Comment 4 Jeremy Katz 2001-07-26 03:48:04 UTC
Fixed in CVS

Comment 5 Daniel Powell 2001-07-26 04:51:36 UTC
yes, dell optiplex system... listed in beta hardware.

NTFS formatted partitions... 
20 or 30G drive... 

filesystem is as follows... (from memory)
[25MB /boot][20G NTFS][256MB swap][rest is linux]

I'll try the installer again tomorrow... the other partitions were ext2 from RH 
7.1 and previous betas... i converted /boot to ext3 and / to reiserfs in the 
installer... ended up having to use tui installer.... 

will test again tomorrow 7/26


Note You need to log in before you can comment on or make changes to this bug.