Bug 498525 - momentary hangs/freezes usually when using firefox
momentary hangs/freezes usually when using firefox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 16:55 EDT by Charles R. Anderson
Modified: 2009-05-15 16:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 16:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (725 bytes, text/plain)
2009-04-30 16:55 EDT, Charles R. Anderson
no flags Details
Xorg.0.log (95.54 KB, text/plain)
2009-04-30 16:59 EDT, Charles R. Anderson
no flags Details
dmesg output (41.42 KB, text/plain)
2009-04-30 17:00 EDT, Charles R. Anderson
no flags Details
gdb backtrace while X is frozen (17.69 KB, text/plain)
2009-04-30 17:03 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2009-04-30 16:55:47 EDT
Created attachment 341998 [details]
xorg.conf

Description of problem:

I'm experiencing frequent momentary hangs/freezes where the entire UI stops updating for several seconds at a time.  The mouse cursor still moves around, but the cursor itself doesn't update when moving the mouse over different UI elements, focus doesn't change, and if the cursor was animated, the animation stops.  5-10 seconds later everything recovers.  This usually happens while interacting with firefox, scrolling pages, etc.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-9.fc11.x86_64
xorg-x11-drv-ati-debuginfo-6.12.2-9.fc11.x86_64
xorg-x11-server-common-1.6.1-9.fc11.x86_64
xorg-x11-server-debuginfo-1.6.1-9.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-9.fc11.x86_64
kernel-2.6.29.1-118.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. start firefox
2. browse around, scroll pages (koji seems to be a pretty reliable reproducer)
  
Actual results:

UI freezes.  Nothing on the screen updates for several seconds.  Typing into existing gnome-terminals seems to buffer keystrokes, but doesn't display the results until seconds later when everything unfreezes.  Mouse cursor moves but the cursor itself doesn't change/animate.

Expected results:
no freezes

Additional info:

Dual-head side-by-side 1600x1200 on DVI's with this card using attached xorg.conf to reserve memory for Virtual resolution:

01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
Comment 1 Charles R. Anderson 2009-04-30 16:59:08 EDT
Created attachment 342002 [details]
Xorg.0.log
Comment 2 Charles R. Anderson 2009-04-30 17:00:37 EDT
Created attachment 342004 [details]
dmesg output
Comment 3 Charles R. Anderson 2009-04-30 17:03:26 EDT
Created attachment 342007 [details]
gdb backtrace while X is frozen
Comment 4 Charles R. Anderson 2009-04-30 17:05:31 EDT
This seems to be the common theme whenever the X server hangs:

pixmanBltsse2 (__P=<value optimized out>) at pixman-sse2.c:4501
4501	            xmm3 = load128Unaligned ((__m128i*)(s+48));
(gdb) thread apply all bt

Thread 1 (Thread 0x7fa8ab9f37b0 (LWP 1916)):
#0  0x000000346763171b in pixmanBltsse2 (__P=<value optimized out>)
   from /usr/lib64/libpixman-1.so.0
#1  0x0000003467620acb in pixman_walk_composite_region (
    compositeRect=<value optimized out>, maskRepeat=<value optimized 
out>, 
    srcRepeat=<value optimized out>, height=<value optimized out>, 
    width=<value optimized out>, yDst=<value optimized out>, 
    xDst=<value optimized out>, yMask=<value optimized out>, 
    xMask=<value optimized out>, ySrc=<value optimized out>, 
    xSrc=<value optimized out>, pDst=<value optimized out>, 
    pMask=<value optimized out>, pSrc=<value optimized out>, 
    op=<value optimized out>) at pixman-pict.c:1371
#2  pixman_image_composite (compositeRect=<value optimized out>, 
    maskRepeat=<value optimized out>, srcRepeat=<value optimized out>, 
    height=<value optimized out>, width=<value optimized out>, 
    yDst=<value optimized out>, xDst=<value optimized out>, 
    yMask=<value optimized out>, xMask=<value optimized out>, 
    ySrc=<value optimized out>, xSrc=<value optimized out>, 
    pDst=<value optimized out>, pMask=<value optimized out>, 
    pSrc=<value optimized out>, op=<value optimized out>) at 
pixman-pict.c:2072
Comment 5 Adam Jackson 2009-05-15 16:43:48 EDT
Should be fixed in ati 6.12.2-11 and later

Note You need to log in before you can comment on or make changes to this bug.