Bug 498542 - need mod_nss "forking model" code in the RHEL version
need mod_nss "forking model" code in the RHEL version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mod_nss (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 443788 496342
  Show dependency treegraph
 
Reported: 2009-04-30 19:48 EDT by Christina Fu
Modified: 2015-01-04 18:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christina Fu 2009-04-30 19:48:52 EDT
urgent customer request to have mod_nss work with nethsm 2000 hardware accelerator.

Found the mod_nss version on Fedora having the exact fix we need: the "NSS forking model."
Porting the code onto RHEL will resolve this urgent issue (have tested that with my own build).
See the following bug for more detail:
https://bugzilla.redhat.com/show_bug.cgi?id=496342

Because of the urgency, we need it spun on Brew for RHCS8.0 early delivery (beta2) early next week.
Comment 4 Rob Crittenden 2009-05-04 15:10:46 EDT
build complete
Comment 7 Kashyap Chamarthy 2010-10-28 14:27:14 EDT
Some Notes from rcrit:
------------------------------------------------------------------
mod_nss 1.0.3 initialized NSS and then forked its child listeners. This was
allowed by older NSS versions but was not the correct thing to do under the
PKCS#11 spec and therefore broke in some hardware readers which enforced the
spec.

mod_nss 1.0.8 initializes NSS after forking each child.

So you basically just need to test that mod_nss still works. If you have access
to a hardware device testing that you can use keys/certs stored on that with
mod_nss would be a good way to test too.

---------------------------------------------------------------
Comment 8 Kashyap Chamarthy 2010-10-31 14:29:56 EDT
Verified:
RHEL5.6(x86_64, i386)
Version: mod_nss-1.0.8-2.el5.x86_64.rpm

mod_nss does work fine with the new build

Successful run of beaker auto tests -- https://beaker.engineering.redhat.com/jobs/27209
Comment 10 errata-xmlrpc 2011-01-13 17:38:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0049.html

Note You need to log in before you can comment on or make changes to this bug.