Bug 498544 - dmraid does't work with Intel ICH9R RAID 5
dmraid does't work with Intel ICH9R RAID 5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 489148
  Show dependency treegraph
 
Reported: 2009-04-30 19:58 EDT by LukasHetzi
Modified: 2009-05-01 08:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-01 03:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Traceback (23.56 KB, text/plain)
2009-04-30 19:58 EDT, LukasHetzi
no flags Details

  None (edit)
Description LukasHetzi 2009-04-30 19:58:06 EDT
Created attachment 342023 [details]
Anaconda Traceback

Description of problem:
I tried the Fedora 11 Preview Live CD
The installation with anaconda wasn't possible, because it crashed. I included the Traceback.

lspci displays the following RAID controller:
00:1f.2 RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)

I also couldn't configure the RAID with dmraid:
[root@localhost ~]# dmraid -ay
ERROR: device-mapper target type "raid45" is not in the kernel
RAID set "isw_deaadhfccd_Volume" was not activated

There is actually no module with the name raid45, but I found a raid456.

Is there anything I can do to get the RAID controller working?

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-102.fc11.x86_64
dmraid-1.0.0.rc15-7.fc11.x86_64
anaconda-11.5.0.47-1.x86_64

How reproducible:
Create a RAID 5 with 4 disks on a Gigabyte GA-P35-DS4 mainboard (Intel ICH9R RAID controller)

Expected results:
Anaconda shows one large disk and raid45 is available and loaded as a module
Comment 1 James Laska 2009-04-30 20:11:36 EDT
Expanding traceback for easy bz searching ...

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/block/__init__.py", line 35, in dm_log
    raise Exception, message
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 719, in get_map
    self._RaidSet__map = _dm.map(name=self.name, table=self.rs.dmTable)
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 822, in activate
    self.map.dev.mknod(self.prefix+self.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1373, in handleUdevDMRaidMemberFormat
    rs.activate(mknod=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1495, in handleUdevDeviceFormat
    self.handleUdevDMRaidMemberFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1167, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1627, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 72, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: device-mapper: reload ioctl failed: Invalid argument
Comment 2 Hans de Goede 2009-05-01 03:51:56 EDT
This does not work because dmraid45 support is not yet in the upstream kernel,
iow its expected to not work, although I admit the traceback is not pretty.

Note You need to log in before you can comment on or make changes to this bug.