Bug 498545 - imputing vars on the cli in the listed order for delegation-add produces Traceback
imputing vars on the cli in the listed order for delegation-add produces Trac...
Status: CLOSED DUPLICATE of bug 498088
Product: freeIPA
Classification: Community
Component: ipa-admintools (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 20:01 EDT by Michael Gregg
Modified: 2015-01-04 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version: jderose@redhat.com
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 16:35:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2009-04-30 20:01:33 EDT
Description of problem:
I realize that it's a somewhat improper use of the tool, but imputing options in the order listed in ipa help delegation-add produces a traceback.
ipa help delegation-add lists usage as: ipa [global-options] delegation-add NAME

Version-Release number of selected component (if applicable):
ipa-server-2.0-2.20090428.el5ipa

How reproducible:
always

Steps to Reproduce:
1. ipa --attributes telephonenumber --source=2 --target=3 delegation-add namef
  
Actual results:
[root@iparhel5-vma etc]# ipa --attributes telephonenumber --source=2 --target=3 delegation-add namef
usage: ipa [options]

ipa: error: no such option: --attributes
Traceback (most recent call last):
  File "/usr/bin/ipa", line 32, in ?
    cli.run(api)
  File "/usr/lib/python2.4/site-packages/ipalib/cli.py", line 679, in run
    api.log.exception('%s: %s', e.__class__.__name__, str(e))
AttributeError: 'API' object has no attribute 'log'


Additional info:
I realize that the more proper usage would be with delegation-add first like:
ipa delegation-add --attributes telephonenumber --source=2 --target=3 namef

I think that this shouldn't throw a traceback.
Comment 1 Rob Crittenden 2009-04-30 20:26:20 EDT
Arguments passed before the command are considered "global" arguments. There is no --attributes argumement so it displayed an error. Seems like we have another place we are catching Exception and not StandardException.
Comment 2 Rob Crittenden 2009-05-04 16:35:02 EDT

*** This bug has been marked as a duplicate of bug 498088 ***

Note You need to log in before you can comment on or make changes to this bug.