Bug 498575 - Windows get maximized to a wrong size
Windows get maximized to a wrong size
Status: CLOSED DUPLICATE of bug 498698
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 04:49 EDT by Ivan Stojmirov
Modified: 2018-04-11 06:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 10:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Stojmirov 2009-05-01 04:49:11 EDT
Description of problem:

I am running F11 on a Lenovo X200 laptop with 1280x800 resolution, as reported by xdpyinfo: 
dimensions:    1280x800 pixels (338x211 millimeters)

However, when i maximize windows in Gnome (metacity), they maximize only up to 1024x768.

I dont have an external monitor connected or anything like that.



Version-Release number of selected component (if applicable):

Fedora 11 with latest updates, running on Lenovo X200 with Intel GMA 4500MHD
graphics.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset
Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset
Integrated Graphics Controller (rev 07)

2.6.29.1-111.fc11.i586 #1 SMP Fri Apr 24 10:42:21 EDT 2009 i686 i686 i386
GNU/Linux

xorg-x11-drv-intel-2.7.0-2.fc11.i586
xorg-x11-server-Xorg-1.6.1-6.fc11.i586



How reproducible:

Try to maximize any window in Gnome.

Steps to Reproduce:
1. Open a new, not-maximized window.
2. Click the maximize button
3. Done
  
Actual results:

Window is maximized only up to 1024x768


Expected results:

Window to be maximized to the actual running resolution (1280x800)


Additional info:

This is the interesting part: once I manually rezise the windows length over the 1024 limit or move it over to the right half of the screen, then it somehow becomes aware of the actual screen size.

And then if I click maximize, everything works as expected.
Comment 1 Howard Ning 2009-05-02 08:44:41 EDT
It is almost the same bug as:
https://bugzilla.redhat.com/show_bug.cgi?id=498698
Comment 2 Matěj Cepl 2009-05-04 10:29:37 EDT
(In reply to comment #1)
> It is almost the same bug as:
> https://bugzilla.redhat.com/show_bug.cgi?id=498698  

I think so.

*** This bug has been marked as a duplicate of bug 498698 ***

Note You need to log in before you can comment on or make changes to this bug.