Bug 498584 - FlightGear 1.9.1 refuses to start up
FlightGear 1.9.1 refuses to start up
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: FlightGear (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Fabrice Bellet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 06:08 EDT by Dululu
Modified: 2009-05-18 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.9.1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 22:07:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dululu 2009-05-01 06:08:56 EDT
Description of problem:
When I try to run FlightGear it doesn't start up, and errors are logged to the console

Version-Release number of selected component (if applicable):
FlightGear 1.9.1 (FlightGear-1.9.1-3.fc11)


How reproducible:
Always

Steps to Reproduce:
1. Run fgfs-wrapper (or fgfs directly) from a console
2.
3.
  
Actual results:
The following is output on console

error type = 1
error type = 1
error type = 1
Segmentation fault

From dmesg, this is the segfault info (from 3 attempts to run FlightGear)

fgfs[2449]: segfault at 1 ip 00c9e9ff sp bfbcc770 error 6 in libsgutil-1.9.1.so[c95000+f000]
fgfs[2461]: segfault at 1 ip 00c9e9ff sp bfce0860 error 6 in libsgutil-1.9.1.so[c95000+f000]
fgfs[2572]: segfault at 1 ip 00c9e9ff sp bff382d0 error 6 in libsgutil-1.9.1.so[c95000+f000]

Expected results:

Expect FlightGear to start up & give me access to flight sim goodness

Additional info:

Latest rawhide as of 01 May 2009).
Machine profile on smolt 
http://www.smolts.org/client/show/pub_5c2b87cb-1e5a-4a5e-82e0-26824557a0e8
Comment 1 Nelson Chan 2009-05-03 13:12:08 EDT
i have faced exactly the same situation.
Comment 2 Fedora Update System 2009-05-11 15:03:34 EDT
FlightGear-1.9.1-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/FlightGear-1.9.1-4.fc11
Comment 3 Fedora Update System 2009-05-11 15:04:07 EDT
SimGear-1.9.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/SimGear-1.9.1-5.fc11
Comment 4 Fedora Update System 2009-05-12 00:04:27 EDT
SimGear-1.9.1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SimGear'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4795
Comment 5 Fedora Update System 2009-05-12 00:07:46 EDT
FlightGear-1.9.1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update FlightGear'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4815
Comment 6 Dululu 2009-05-13 13:25:43 EDT
Update works for me. FlightGear now starts.
Comment 7 Fedora Update System 2009-05-18 22:06:55 EDT
FlightGear-1.9.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-05-18 22:11:20 EDT
SimGear-1.9.1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.