This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 498599 - Intermittent playback glitching in rhythmbox with iPod
Intermittent playback glitching in rhythmbox with iPod
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 08:45 EDT by Mark Watts
Modified: 2009-09-14 06:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 06:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Watts 2009-05-01 08:45:05 EDT
I have the latest updates of RhythmBox and the gstreamer plugins.

I'm trying to play MP3 and M4A files from my USB iPod through RhythmBox, but several times during each song there is a tiny pause in playback, as though a buffer isn't being filled fast enough.

System is a Dell Precision 670 workstation (Two Xeon 2.8GHz chips with HT on, and 4GB ram), using the onboard Intel AC'97 audio card:

00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

CPU usage is negligible during playback.
Comment 1 Mark Watts 2009-05-01 10:51:16 EDT
Listening to a bunch more songs, its not pausing for a very short time, its almost as though it's muting for a very short time, since if it happens in the middle of someone singing a word, part of the word is missing.
Comment 2 Christopher Beland 2009-07-17 15:10:26 EDT
What are the version numbers of the RPMs you are using (e.g. from "rpm -q rhythmbox")?  A minor update has been released for Fedora 10 since this bug was reported.

I'm not experiencing this problem, but I am using rhythmbox-0.12.1-3.fc11.i586 (Fedora 11) and a non-iPod MP3 player.  It's possible there's an easily reproducable problem when using the specific hardware (which is widely available) but in the meantime, there are a few things you could check...

I assume there are no glitches if you play the music on the iPod itself (e.g. through headphones)?

It seems unlikely, but if you run "top" do you see any process with status "D"?  This would indicate disk wait...I'm wondering if the USB connection is simply reaching capacity?  Do you have other USB devices which are active at the same time?

Most importantly, do you see any error messages in /var/log/messages or in the output of "rhythmbox -d" during these glitches?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Mark Watts 2009-09-14 06:59:10 EDT
This seems to be related to the issues I'm seeing with the intel aound driver and pulseaudio.

Setting 

load-module module-hal-detect tsched=0

in default.pa fixes this glitching problem, along with other issues.

Note You need to log in before you can comment on or make changes to this bug.