Bug 498629 - Support cases and software downloads do not use same versions for products
Support cases and software downloads do not use same versions for products
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: Web-General (Show other bugs)
GovernanceBoard
All Linux
medium Severity medium
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 11:14 EDT by John Sanda
Modified: 2011-01-05 13:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 13:25:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sanda 2009-05-01 11:14:02 EDT
Description of problem:
If you create a case for Application Platform (EAP), in the version pick list you will see 4.3.0.GA, 4.2.0.GA, and 4.2.0.CP1. If you go over to Software Downloads and select Application Platform, in the version pick list, you will find a much longer list of version numbers from which to choose.

The reason for this discrepancy is because on the support side, the versions table is looked at to determine the possible versions. The versions table is also used by Issue Tracker. On the software downloads side, version numbers come from the software table.

This is problematic on a number of levels. Consider this scenario. A customer downloads bits for EAP 4.3.0.GA_CP03. The customer then wants to open a ticket against that product. He does not see 4.3.0.GA_CP03 in the case creation screen. The customer might choose to open a separate ticket complaining that the right version is not there. Or the customer may elect to choose a different. Either way, this could potentially lead to lots of confusion and a lot of extra work.

I think that the best solution is to use the versions table across the board. This will impact CSP and SEP, and possibly Issue Tracker.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This problem is really symptomatic of a larger issue in which CSP is using to different data models (i.e., schemas) for support and for downloads. For support the tables that are used by Issue Tracker are used. Downloads relies on different tables. This creates a number of problems on a number of levels.
Comment 1 Tom Mirc 2009-05-04 09:21:38 EDT
I agree with John's analysis.  The separate data models create divergent data that is published to our customers, resulting in confusion and numerous support tickets. 

One area that we must focus on is in understanding the current business process around the population of support data.  I have identified 3 individuals who have populated the support version fields via Issue-Tracker.  They are in various business departments (IT, GSS, DataOps).  The current business process and actors need to be thoroughly identified prior to the change being made to mitigate risk/confusion/business discontinuity.
Comment 2 David Spalding 2011-01-05 13:25:02 EST
Superceded by Avalon.

Note You need to log in before you can comment on or make changes to this bug.