Bug 49867 - poweroff won't power off Compaq 12XL125
Summary: poweroff won't power off Compaq 12XL125
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-24 18:11 UTC by Chris Ricker
Modified: 2007-04-18 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 17:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-07-24 18:11:30 UTC
APM options in the default kernel are incorrect for poweroff to work on
Compaq 12XL125 laptops

Comment 1 Glen Foster 2001-07-24 20:31:21 UTC
So what are the correct options?

Comment 2 Chris Ricker 2001-07-26 14:30:59 UTC
With 2.4.2 on 7.1, I used:

CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
CONFIG_APM_DO_ENABLE=y
CONFIG_APM_CPU_IDLE=y
# CONFIG_APM_DISPLAY_BLANK is not set
# CONFIG_APM_RTC_IS_GMT is not set
CONFIG_APM_ALLOW_INTS=y
# CONFIG_APM_REAL_MODE_POWER_OFF is not set


I'm still having kernel compile issues with FairFax, so I've not confirmed that
they work there....

Comment 3 Arjan van de Ven 2001-07-30 14:21:01 UTC
please try booting with the "apm=allow-ints" kernel commandline option


Comment 4 Kjartan Maraas 2001-08-06 17:55:06 UTC
It worked for me until recently, but after installing the beta kernels it
started failing again. I have to use apm -s to suspend the machine. It doesn't
respond to the suspend button at all. Also, if I have my USB-mouse attached it
fails to suspend at all.


Comment 5 Kjartan Maraas 2001-08-06 18:00:11 UTC
I forgot to mention that I have a Compaq Armada M300.


Comment 6 Chris Ricker 2001-08-10 16:24:05 UTC
apm=allow-ints works for me with 2.4.7-0.3

Comment 7 Arjan van de Ven 2001-08-10 16:33:05 UTC
If apm=allow_ints works, please download

http://people.redhat.com/arjanv/dmidecode.c

and (as root)

gcc dmidecode.c -o dmidecode
./dmidecode | mail -s "needs apm=allow_ints" hardwarebugs-list@redhat.com

(please check the program out without the mail part, so you can see what it will 
mail)

Comment 8 Chris Ricker 2001-09-05 17:50:06 UTC
with the kernel from RC2, neither the default kernel or the default +
apm=allow-ints will power off the machine

this used to work with older Red Hat releases after I recompiled the kernel

Comment 9 Chris Ricker 2001-10-01 13:43:16 UTC
Still true with 2.4.7-10 in RH 7.2 release.  I can't find any way to get the
machine to power off.  This is a regression from 7.1

Comment 10 Pete Zaitcev 2002-01-26 00:04:57 UTC
Sure this bug is not NEW anymore?

Did we get the DMI dump with dmidecode?
I'll mark as NEEDINFO if not.


Comment 11 Chris Ricker 2002-02-11 01:35:31 UTC
I sent in the dmidecode info months ago....  I can do it again if it's still needed.

At any rate, I just put hampton beta1 on there, and it has the same problem with
poweroff.

Comment 12 Wendy Hung 2002-02-25 18:33:09 UTC
Also seen on a few IBM xSeries boxes with Red Hat 7.2 and Hampton beta1.  
Conflict between ACPI enabled kernels and APM?

Comment 13 Arjan van de Ven 2002-02-25 18:35:17 UTC
wendyh@us.ibm.com: no since we don't enable ACPI.

Comment 14 Wendy Hung 2002-03-08 16:28:53 UTC
Fixed in Hampton Beta2.  Verified on an IBM xSeries 200 8479 model.

Comment 15 Chris Ricker 2002-03-08 18:38:06 UTC
beta2 still doesn't power off for me....

Comment 16 Wendy Hung 2002-03-08 21:23:55 UTC
poweroff still fails to poweroff the machine
on an IBM xSeries 232 and 350.  Screen stays at: "Power Down".

On a x232, using the kernel parameters "apm=power-off" and
"apm=realmode-power-off" also failed. In each case, there is a
kernel message during boot that says "apm: BIOS not found." 

On a x300, however, while booting the message is 
"apm: BIOS version 1.12 Flags 0x087 (Driver version 1.16)", 
and the apmd daemon loads later on.   Poweroff works.


Comment 17 Arjan van de Ven 2002-03-08 21:30:11 UTC
On machines without APM of course poweroff doesn't work....
Linux needs APM support from the bios to do APM poweroff.

Comment 18 Chris Ricker 2002-03-17 06:28:39 UTC
Here's the score on the Compaq 12XL125 with 2.4.18-0.4

enable APM BIOS Support and RTC stores in GMT -- machine hangs powering off

enable APM BIOS Support, RTC, and Allow interrupts -- machine hangs powering off

enable APM BIOS Support, RTC, Allow interrupts, and Use real mode BIOS call --
machine reboots when powered off

Comment 19 Chris Ricker 2002-10-04 22:09:53 UTC
Just for the record, it still doesn't power off with 8.0 (2.4.18-14)


Note You need to log in before you can comment on or make changes to this bug.