Bug 498676 - OpenLayers denies access from localhost.localdomain
OpenLayers denies access from localhost.localdomain
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openlayers (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 16:32 EDT by Mathieu Bridon
Modified: 2009-06-30 17:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 17:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Bridon 2009-05-01 16:32:52 EDT
Description of problem:
As is, the openlayers package is not usable on Fedora 11.

It is configured as follows:
    Order Deny,Allow
    Deny from all
    Allow from localhost

However, when calling the URL http://localhost/openlayer/OpenLayers.js, I can see in the apache logs:

==> access_log <==
localhost.localdomain - - [01/May/2009:22:30:02 +0200] "GET /openlayers/OpenLayers.js HTTP/1.1" 403 301 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en; rv:1.9.1b4) Gecko/20080528 Fedora/2.26.1-2.fc11 Epiphany/2.22 Firefox/3.5"

==> error_log <==
[Fri May 01 22:30:02 2009] [error] [client 127.0.0.1] client denied by server configuration: /usr/share/openlayers/www/OpenLayers.js

Access is denied, I get a « 403 Forbidden » error.

As you can see, access is allowed only for « localhost », but apache sees my client as « localhost.localdomain »

So, openlayers.conf should allow access for « localhost.localdomain ». That would make it work out of box :)

I simply added the line:
    Allow from localhost.localdomain


Version-Release number of selected component (if applicable):
openlayers-2.7-3.fc11.x86_64


How reproducible:
Always
Comment 1 Bug Zapper 2009-06-09 10:58:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mathieu Bridon 2009-06-30 17:17:30 EDT
I'm not sure what happened then, but it looks like it was a bug from my installation of Fedora 11 (not yet released at this time).

I noticed that the /etc/hosts I had and the one shipped right now in Fedora 11 are different. So I tried to replace mine with the one from the current setup-2.8.3 package.

This issue doesn't happen anymore, so it doesn't seem to have been an openlayers issue.

Closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.