Bug 498681 - Can hear audio in skype, not in any other program
Can hear audio in skype, not in any other program
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 17:10 EDT by Dhaval Giani
Modified: 2009-05-05 15:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 12:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vvv (73.17 KB, application/octet-stream)
2009-05-05 12:32 EDT, Dhaval Giani
no flags Details

  None (edit)
Description Dhaval Giani 2009-05-01 17:10:24 EDT
Description of problem:
Cannot hear audio in applications except for skype. Please note, this problem is irrespective of the fact whether skype is running or not.

Have maxxed every knob in alsamixed -c0 but even that does not help in this case.

Version-Release number of selected component (if applicable):

[dhaval@mordor ~]$ rpm -qv pulseaudio
pulseaudio-0.9.15-11.fc11.x86_64
[dhaval@mordor ~]$


How reproducible:
Always

Additional info:

Partial output of pulseaudio -vvv is available at http://fpaste.org/paste/10749 . Will upload a newer output once I get to that machine again.
Comment 1 Lennart Poettering 2009-05-05 12:03:09 EDT
If you run "pavucontrol" do you see signal on meter for your input device?
Comment 2 Dhaval Giani 2009-05-05 12:08:22 EDT
yes, i do see signal.
Comment 3 Lennart Poettering 2009-05-05 12:32:19 EDT
Is it possible that the failing applications are recording from the wrong device?

please run pavucontrol while you record like this and right-click on the record stream and check if you need to move the stream to the right device.
Comment 4 Dhaval Giani 2009-05-05 12:32:32 EDT
Created attachment 342489 [details]
pulseaudio -vvv

pulseaudio -vvv
Comment 5 Dhaval Giani 2009-05-05 12:38:48 EDT
Changing to output analog stereo got the sound back. nothing with digital stereo though. is that expected?
Comment 6 Lennart Poettering 2009-05-05 12:44:51 EDT
ah, so recording works, and playback didn't. I misunderstood that.

Do you have digital equipment via SPDIF connected to your machine? If you haven't then of course only analog output works.
Comment 7 Dhaval Giani 2009-05-05 12:58:37 EDT
No SPDIF. So you are right, only analog will work
Comment 8 Lennart Poettering 2009-05-05 15:08:43 EDT
Ok, the problem was probably caused by pa starting up while the analog audio device was blocked by some other tool. That caused it to use the only remaining device then which was analog. It then remembered that setting. Now that you switched it back PA should remember.

Note You need to log in before you can comment on or make changes to this bug.