Bug 498688 - Please build latest libical for EPEL 4 and 5
Please build latest libical for EPEL 4 and 5
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: libical (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 498194
  Show dependency treegraph
 
Reported: 2009-05-01 18:58 EDT by Robert Scheck
Modified: 2009-05-06 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.43-4.el4, 0.43-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 18:47:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-05-01 18:58:16 EDT
Description of problem:
Please build latest libical for EPEL 4 and 5, the 0.4x package from Rawhide.
Because libical >= 0.42 is what Zarafa requires. 

As far as I can see, only sunbird requires libical on EPEL and this only on
EPEL 5. When looking to Rawhide, building sunbird with newer libical should
work as well - adding sunbird maintainer on Cc to verify that.

Version-Release number of selected component (if applicable):
libical-0.32-1.el5

Actual results:
libical-0.32-1.el5

Expected results:
libical-0.43-4.el5
Comment 1 Robert Scheck 2009-05-01 19:07:36 EDT
I noticed, that libical is EL-5 only currently. Is there any interest by the
libical maintainers to branch and maintain EL-4 as well?
Comment 2 Lubomir Rintel 2009-05-02 06:14:18 EDT
I built the new version in EL-5 branch and verified that it's binary compatible with the older one for sunbird to run.

Handing the bug over to Rishi to decide about the EL-4 branch (I have not interest in it).
Comment 3 Debarshi Ray 2009-05-02 08:05:40 EDT
Although I have no interest in EL-4, I would not object to anyone else who might want to do it. Robert, would you be interested in doing it yourself?
Comment 4 Robert Scheck 2009-05-02 08:19:04 EDT
I verified, that sunbird is still building with newer libical in case if it
shouldn't be binary compatible with the older version.

As libical will be a dependency of my Zarafa package, I think, I'm going to
maintain it on EL-4. Lubomir, question for me is, whether you still want to
care about libical on EL-5 or not (when remembering to our yesterday IRC
talk where you've mentioned, that you're using sunbird no longer that active
as in the past)? Means in the end, that I would be willing to maintain the
libical package on EL-4 and EL-5 even. Maybe you can let me know about this.
Comment 5 Robert Scheck 2009-05-02 10:53:28 EDT
[16:39:24] < rsc> lkundrak: I made a comment to the libical bug, maybe you can let me know.
[16:45:02] < lkundrak> rsc: so you'd like to take care of libical in EL-5? I can orphan it in pkgdb, you can take it then
[16:45:26] < rsc> lkundrak: okay, we can do that, if it's okay for you
[16:47:58] < lkundrak> rsc: I released the package. Feel free to take it. And thanks! https://admin.fedoraproject.org/pkgdb/packages/name/libical#FedoraEPEL5
[16:48:16] < rsc> lkundrak: Taken. Do you want me to approve watch*, commit*, approve*?
[16:49:39] < lkundrak> rsc: no need to. I don't even remember applying for it, dunno why it's there :)
[16:50:04] < rsc> lkundrak: okay, so I would remove you then. If you some day want to change it, just let me know ;)
Comment 6 Robert Scheck 2009-05-02 10:54:50 EDT
Package Change Request
======================
Package Name: libical
New Branches: EL-4
Owners: robert
Comment 7 Kevin Fenzi 2009-05-06 18:09:58 EDT
cvs done.
Comment 8 Robert Scheck 2009-05-06 18:47:10 EDT
2200 (libical): Build on target fedora-4-epel succeeded.

Note You need to log in before you can comment on or make changes to this bug.