Bug 49872 - gmc crashes sometimes on startup / or wont be shut off
Summary: gmc crashes sometimes on startup / or wont be shut off
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gmc   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-24 18:41 UTC by Joe Acosta
Modified: 2013-04-02 04:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 18:48:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Acosta 2001-07-24 18:41:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
It seems that sometimes gmc crashes on startup.  I am using Windowmaker as the window manager with gnome.
I use startx to start X (not gdm or xdm)
gmc sometimes starts and then dies, and then gets restarted.

Also it seems that I cannot kill gmc, without it restarting itself.  

The icons get deleted and then they replace themselves on the desktop (I no longer want desktop icons) even if you save the session they 
come back in the next session.



How reproducible:
Sometimes

Steps to Reproduce:
1. delete a 'default' icon (floppy, home, etc)
2. save your gnome session
3. exit gnome
4. restart x, they are back

1. kill -9 gmc (the pipd of gmc of course)
2. watch it restart itself.

1. sometimes when gmc starts it crashes.  not sure why then it restarts itself
	

Additional info:

Comment 1 Jonathan Blandford 2001-07-30 18:09:30 UTC
gmc restarts itself because it is in the session manager as Respawn.  You can
run 'session-properties' to remove it.  Additionally, it tries to recreate your
devices on startup.  I don't see this behavior changing.


Note You need to log in before you can comment on or make changes to this bug.