Bug 498724 - python-setuptools has NameError on python setup.py sdist
python-setuptools has NameError on python setup.py sdist
Status: CLOSED DUPLICATE of bug 460631
Product: Fedora EPEL
Classification: Fedora
Component: python-setuptools (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 11:18 EDT by Thomas Vander Stichele
Modified: 2009-05-08 00:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 00:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2009-05-02 11:18:14 EDT
Description of problem:

Packaging a certain egg, a NameError gets hit:


[root@betsy 0.11]# python setup.py sdist
running sdist
running egg_info
writing TracTocMacro.egg-info/PKG-INFO
writing top-level names to TracTocMacro.egg-info/top_level.txt
writing dependency_links to TracTocMacro.egg-info/dependency_links.txt
writing entry points to TracTocMacro.egg-info/entry_points.txt
Traceback (most recent call last):
  File "setup.py", line 23, in ?
    entry_points = {
  File "/usr/lib64/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib64/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.4/site-packages/setuptools/command/sdist.py", line 141, in run
    self.run_command('egg_info')
  File "/usr/lib64/python2.4/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 171, in run
    self.find_sources()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 252, in find_sources
    mm.run()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 306, in run
    self.add_defaults()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 333, in add_defaults
    rcfiles = list(walk_revctrl())
  File "/usr/lib/python2.4/site-packages/setuptools/command/sdist.py", line 45, in walk_revctrl
    for item in ep.load()(dirname):
  File "/usr/lib/python2.4/site-packages/setuptools/command/sdist.py", line 52, in _default_revctrl
    for path in finder(dirname,path):
  File "/usr/lib/python2.4/site-packages/setuptools/command/sdist.py", line 98, in entries_finder
    log.warn("unrecognized .svn/entries format in %s", dirname)
NameError: global name 'log' is not defined

Looking at the code, there is indeed no import statement to import the 'log' name, so this is clearly a bug.

Version-Release number of selected component (if applicable):

[root@betsy 0.11]# rpm -qi python-setuptools
Name        : python-setuptools            Relocations: (not relocatable)
Version     : 0.6c7                             Vendor: Fedora Project
Release     : 1.el5                         Build Date: Fri 14 Sep 2007 10:21:30 PM CEST
Install Date: Sat 11 Apr 2009 12:14:39 PM CEST      Build Host: ppc2.fedora.redhat.com
Group       : Development/Languages         Source RPM: python-setuptools-0.6c7-1.el5.src.rpm
Size        : 1677213                          License: Python or ZPLv2.0
Signature   : DSA/SHA1, Sat 15 Sep 2007 01:11:05 AM CEST, Key ID 119cc036217521f6
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://peak.telecommunity.com/DevCenter/setuptools
Summary     : Download, build, install, upgrade, and uninstall Python packages
Description :
setuptools is a collection of enhancements to the Python distutils that allow
you to more easily build and distribute Python packages, especially ones that
have dependencies on other packages.


How reproducible:

always
Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Konstantin Ryabitsev 2009-05-08 00:56:15 EDT

*** This bug has been marked as a duplicate of bug 460631 ***

Note You need to log in before you can comment on or make changes to this bug.