Bug 498727 - Live DVD startup freezes on starting X with garbled screen output - possible Radeon XPRESS 200 issue
Live DVD startup freezes on starting X with garbled screen output - possible ...
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 11:35 EDT by Tibor Futo
Modified: 2009-05-25 18:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 18:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora 11 preview Live DVD X log (33.60 KB, text/plain)
2009-05-03 06:15 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD /var/log/messages (47.25 KB, text/plain)
2009-05-03 06:16 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD /var/log/kdm.log (1.24 KB, text/plain)
2009-05-03 06:16 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD /var/log/boot.log (3.77 KB, text/plain)
2009-05-03 06:17 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD with xvideo=vesa /var/log/messages (46.42 KB, text/plain)
2009-05-06 16:32 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD with xvideo=vesa, /var/log/Xorg.0.log (33.83 KB, text/plain)
2009-05-06 16:33 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD with xvideo=vesa, first ps -ejH (5.11 KB, text/plain)
2009-05-06 16:33 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD with xvideo=vesa, second ps -ejH (5.13 KB, text/plain)
2009-05-06 16:34 EDT, Tibor Futo
no flags Details
Fedora 11 preview Live DVD with xvideo=vesa, third ps -ejH (5.53 KB, text/plain)
2009-05-06 16:34 EDT, Tibor Futo
no flags Details

  None (edit)
Description Tibor Futo 2009-05-02 11:35:16 EDT
Description of problem:
Unable to pass through the X startup sequence because X seems to freeze on startup. Most probably this is related to the Radeon XPRESS 200 chipset.

Version-Release number of selected component (if applicable):
Fedora 11 Release Preview Live DVD

How reproducible: Constant

Steps to Reproduce:
1. Insert Fedora 11 Release Preview LIVE DVD
2. See the frozen X screen
  
Actual results:
X is frozen, screen image contains random binary data, but the mouse pointer shows correctly on top of it, however, it seems that it is the basic X mouse pointer and not some fancy theme pointer. Pointer is completely frozen, however, the Live DVD spins up after a while and keeps loading for about 30 seconds, so the kernel might still be alive.


Expected results:
Working desktop.


Additional info:

I think I had a stability issue with Radeon XPRESS 200 on Fedora 10 too, although I can't confirm it for sure (freezes, lock-ups). Debian Lenny is rock solid with default driver, completely messed up and can't start with newer Ati/AMD drivers.

Configuration (using Debian Lenny, hwinfo --short):

cpu:
                       Intel(R) Pentium(R) 4 CPU 3.00GHz, 3000 MHz
                       Intel(R) Pentium(R) 4 CPU 3.00GHz, 3000 MHz
keyboard:
  /dev/input/event1    EzKEY USB-compliant keyboard
mouse:
  /dev/input/mice      EzKEY USB-compliant keyboard
  /dev/input/mice      Macintosh mouse button emulation
  /dev/input/mice      ImPS/2 Generic Wheel Mouse
graphics card:
                       ATI Radeon XPRESS 200 5A41 (PCIE)
sound:
                       ALi High Definition Audio/AC'97 Host Controller
storage:
                       Floppy disk controller
                       ALi ULi 5287 SATA
                       ALi M5229 IDE
                       IDE interface
network:
  eth0                 ASUSTeK Marvell 88E8001 Gigabit Ethernet Controller (Asus)
network interface:
  ppp0                 Network Interface
  eth0                 Ethernet network interface
  lo                   Loopback network interface
disk:
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06068 SAMSUNG SP2014N
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06072 SAMSUNG SP2014N
partition:
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06068-part1 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06068-part2 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06068-part3 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06068-part4 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06072-part1 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06072-part2 Partition
  /dev/disk/by-id/ata-SAMSUNG_SP2014N_S088J1FYA06072-part3 Partition
cdrom:
  /dev/disk/by-path/pci-0000:00:1f.0-ide-0:1 _NEC DVD_RW ND-3540A
usb controller:
                       ALi USB 2.0 Controller
                       ALi USB 1.1 Controller
                       ALi USB 1.1 Controller
                       ALi USB 1.1 Controller
bios:
                       BIOS
bridge:
                       ALi M7101 Power Management Controller [PMU]
                       ALi PCI to LPC Controller
                       ALi M5249 HTT to PCI Bridge
                       ATI RS480 PCI-X Root Port
                       ATI RS480 PCI Bridge
                       ATI Radeon Xpress 200 Host Bridge
hub:
                       Linux 2.6.26-2-vserver-amd64 ehci_hcd EHCI Host Controller
                       Linux 2.6.26-2-vserver-amd64 ohci_hcd OHCI Host Controller
                       Linux 2.6.26-2-vserver-amd64 ohci_hcd OHCI Host Controller
                       Linux 2.6.26-2-vserver-amd64 ohci_hcd OHCI Host Controller
memory:
                       Main Memory
unknown:
                       FPU
                       DMA controller
                       PIC
                       Timer
                       Keyboard controller
                       PS/2 Controller
  /dev/ttyS0           16550A
Comment 1 Tibor Futo 2009-05-02 12:27:03 EDT
Actually I tried to boot one more and I was incorrect: 
- X does start and I see the infinity animation, and then 
- there is a resolution change probably, and 
- after that shows the random chaos on the screen.
- Mouse pointer is working for about 5 seconds, then freezes, DVD spins up, and some software is being loaded, then DVD spins down,
- Then there is a huge delay (5 minutes), the system seems to be frozen.
- Then the DVD spins up, and the mouse pointer is alive again for about 10 seconds, then the system seems to be frozen again, keyboard Num-Lock dead, nothing happens for about 10 minutes, then I gave up.

Actually what I say as random data has some periodic texture in it, it looks purple, but at the beginning there is a section that has the same color as the boot animation greenish blue, so it very well may be that the resolution switching does not work.

How this causes a complete system hang though, I do not know :-).
Comment 2 Matěj Cepl 2009-05-02 15:35:17 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Tibor Futo 2009-05-03 06:15:33 EDT
Created attachment 342211 [details]
Fedora 11 preview Live DVD X log
Comment 4 Tibor Futo 2009-05-03 06:16:13 EDT
Created attachment 342212 [details]
Fedora 11 preview Live DVD /var/log/messages
Comment 5 Tibor Futo 2009-05-03 06:16:56 EDT
Created attachment 342213 [details]
Fedora 11 preview Live DVD /var/log/kdm.log
Comment 6 Tibor Futo 2009-05-03 06:17:27 EDT
Created attachment 342215 [details]
Fedora 11 preview Live DVD /var/log/boot.log
Comment 7 Tibor Futo 2009-05-03 06:18:16 EDT
Hello,

  There is no log at all such as /tmp/X* and as /var/log/anaconda.xlog.

  Actually after starting and what I described, I could successfully start the tty-based session, and could work without any trouble in text mode. I checked the processes with top, and X was using 99.7-100% of CPU time... I killed that process, then I jumped back suddenly to graphical mode, and I saw a different screen image, same random-like stuff, greenish and a cube-shaped very vague something, repeating.

  Please note that I have a ViewSonic 24" monitor and using it using the standard VGA (analog) connection, I do not know if that is relevant.

  I attach those log files that may help and I could find.
Comment 8 François Cami 2009-05-06 06:55:07 EDT
Tibor,

Can you install using xvideo=vesa in the installer boot prompt ?
If that works, the following builds in Koji contain IGP-related fixes :

http://koji.fedoraproject.org/koji/buildinfo?buildID=100894
http://koji.fedoraproject.org/koji/buildinfo?buildID=100998
http://koji.fedoraproject.org/koji/buildinfo?buildID=100995

Could you test them and report ?
If there are any problems, please post /var/log/messages with drm.debug=1 in the kernel command line and Xorg.0.log as uncompressed text/plain attachments to this bug.

Thanks in advance

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Tibor Futo 2009-05-06 16:31:20 EDT
Hello François,

  I have tried booting both with rhgb xvideo=vesa and without rhgb. The same thing happens, have the pink missed-framebuffer-like screen, and now the mouse is alive. It starts showing the KDE blue circle animation on the pointer, then the animation freezes (stays on the mouse pointer), but the mouse move action and display is good. It obeys the screen limit, does not leave trail, it works exactly as expected.

  The keyboard is dead if I do not change to tty the minute this pinkish screen shows up.

  After a while it gets a white 1/5 screen strip and the rest is green with some periodic texture. Mouse works very nice, keyboard is not working (Numlock does not respond, etc.)

  I found in /var/log/messages the following: "[drm] writeback test failed". Maybe this is a framebuffer issue?

  I did a ps -ejH at several phases, one at just after the pink garbled screen, then the "ksplash_scale" process goes <defunct>, and it stays that for about 3-5 minutes. Then more action on the DVD, and "kcminit_startup" shows up, and then probably I should do something, but I don't see what. 

  I attach the current Xorg.0.log.

  Well, sorry that I can't give you more data.

Tibor
Comment 10 Tibor Futo 2009-05-06 16:32:27 EDT
Created attachment 342713 [details]
Fedora 11 preview Live DVD with xvideo=vesa /var/log/messages
Comment 11 Tibor Futo 2009-05-06 16:33:09 EDT
Created attachment 342714 [details]
Fedora 11 preview Live DVD with xvideo=vesa, /var/log/Xorg.0.log
Comment 12 Tibor Futo 2009-05-06 16:33:59 EDT
Created attachment 342715 [details]
Fedora 11 preview Live DVD with xvideo=vesa, first ps -ejH
Comment 13 Tibor Futo 2009-05-06 16:34:20 EDT
Created attachment 342717 [details]
Fedora 11 preview Live DVD with xvideo=vesa, second ps -ejH
Comment 14 Tibor Futo 2009-05-06 16:34:43 EDT
Created attachment 342718 [details]
Fedora 11 preview Live DVD with xvideo=vesa, third ps -ejH
Comment 15 Jens Petersen 2009-05-09 06:24:24 EDT
Earlier with rawhide Live on my Radeon XPRESS200 box I think radeon was locking up after plymouth but with latest rawhide it seems to oops before that (maybe at KMS?).

That's with xorg-x11-drv-ati-6.12.2-11.fc11.i586.
Comment 16 Jens Petersen 2009-05-09 06:29:47 EDT
(oh and no more garbled screen - just black screen with flashing cursor.)

Let me transcribe the last console kernel boot messages:

radeon 0000:01:05.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[drm] Detected VRAM RAM=65536K, accessible=65536K, BAR=262144K
Comment 17 Mitch Davis 2009-05-25 09:26:37 EDT
Duplicate of bug 498457?
Comment 18 Matěj Cepl 2009-05-25 18:54:53 EDT
(In reply to comment #17)
> Duplicate of bug 498457?  

Looks like so.

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.