Bug 498733 - Make it easy to grab uqm content once and have it available for all users
Make it easy to grab uqm content once and have it available for all users
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: uqm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 12:41 EDT by Bruno Wolff III
Modified: 2010-04-28 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 12:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-05-02 12:41:25 EDT
Description of problem:
When I run uqm it downs a significant amount of content (over 100MB) and places it in my home directory. If another user wants to also play the game the content gets downloaded again. Looking at the script that gets run and available options on the real uqm binary, it looks like I will be able to figure out where to copy the data to and change the script to start uqm pointing to the shared location for the data rather than the home directory.
It would be nice if the figuring out part could be skipped. Maybe detect that the initial script is being run as root and download into a shared area instead of a home directory (and probably not actually start the game). The script could also be modified to check if there is an existing copy of the correct version in the shared area or the home directory before trying to downlaod a copy.

Version-Release number of selected component (if applicable):
uqm-0.6.2-8.fc11

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2010-03-23 17:51:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Gwyn Ciesla 2010-04-28 12:28:37 EDT
I don't think this is feasible.  In almost no case will a user be running uqm as root (please $_DEITY let that be true), and the alternative would be to port autodownloaded to C++, since I don't think setuid root python scripts are possible.  I agree that this would be highly valuable on multiuser systems, but I can't think of a good way to do it.

Or, I suppose we could create a common directory for autodownloader to download to that any user could write to, but then a malicious user could remove the data or replace it with malicious data.  Farfetched, but it makes me nervous.

Note You need to log in before you can comment on or make changes to this bug.