Bug 498739 - Gnote Applet has no icon
Gnote Applet has no icon
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnote (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 12:57 EDT by You
Modified: 2013-03-13 01:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.3.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 09:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description You 2009-05-02 12:57:01 EDT
Description of problem:
Gnote 0.3.0 has applet support, but when adding the applet, it is "invisible" as there is no icon shown.

Version-Release number of selected component (if applicable):
0.3.0


Steps to Reproduce:
1. Right click panel, choose "add to panel"
2. scroll down and then choose gnote"
3. Nothing will show on the panel, but if you click where you added the applet, it will be there.
  
Actual results:
Invisible applet.

Expected results:
An applet icon to show in the panel

Additional info:

There is also another applet in the options called "sticky notes". I am unsure if this is also linked with gnote, or if it is a separate application?
Comment 1 Rahul Sundaram 2009-05-02 17:27:57 EDT
Can't reproduce the problem here.  I see the icon without any issues. whats the output of rpm -qi gnote

sticky notes is not connected to gnote.
Comment 2 You 2009-05-02 20:43:10 EDT
I have just tried to change the icon themes to see if it makes a difference, but no (I use echo by default). Thanks for the rest of the information, and here is the output from rpm -qi gnote:
Name        : gnote                        Relocations: (not relocatable)
Version     : 0.3.0                             Vendor: Fedora Project
Release     : 1.fc11                        Build Date: Fri 01 May 2009 13:56:58 BST
Install Date: Sat 02 May 2009 14:41:50 BST      Build Host: xenbuilder2.fedora.redhat.com
Group       : User Interface/Desktops       Source RPM: gnote-0.3.0-1.fc11.src.rpm
Size        : 3727673                          License: GPLv3+
Signature   : (none)
Packager    : Fedora Project
URL         : http://live.gnome.org/Gnote
Summary     : Note-taking application
Description :
Gnote is a desktop note-taking application which is simple and easy to use.
It lets you organize your notes intelligently by allowing you to easily link
ideas together with Wiki style interconnects. It is a port of Tomboy to C++
and consumes less resources.
Comment 3 Rahul Sundaram 2009-05-03 12:45:42 EDT
Did you get the package directly from Koji? I ask because it is not pushed into the repos yet due to the development freeze.  Also, can you create a new user and login and try to see if you can reproduce the problem there? That would eliminate local configuration issues such as theme changes.
Comment 4 You 2009-05-03 13:09:38 EDT
Yes, I got the package from koji.

I have tested on a newly created account and still the same issue.

Just to be clear, I am NOT talking about the icon that appears in the system tray if you go to Applications >> Accessories >> Gnote - the icon here shows properly in the system tray.

The icon I am talking about is if you right click a panel, click add to panel and then choose gnote. No icon shows, but if you click again in the area where you had clicked to add the icon (or click alt+f12), you can interact with gnote.
Comment 5 Rahul Sundaram 2009-05-03 13:24:19 EDT
Yes, I understand what you mean but unfortunately I can't reproduce it. The only obvious difference I can see is that mine is a x86 box while you are using x86_64. I don't have a x86_64 box to test now.
Comment 6 Rahul Sundaram 2009-05-03 14:46:59 EDT
I have a report of the same problem in Fedora 10 on a x86 box as well

https://admin.fedoraproject.org/updates/gnote-0.3.0-1.fc10

Still trying to understand what's going on.
Comment 7 Rahul Sundaram 2009-05-04 11:52:13 EDT
Ok, filed it upstream and the issue is that you will get the icon only if Tomboy is already installed on your system.

http://bugzilla.gnome.org/show_bug.cgi?id=581226

It has been fixed in the git tree. I will wait for the next release. Thanks for reporting the bug.
Comment 8 mkaz 2009-05-05 09:52:00 EDT
I faced a similar problem as described by naheem when I used the ubuntu ppa build. I found it was compiled without libpanelappletmm-2.6-dev available. I found the applet part was not compiled and GNOME_GnoteApplet.server was not installed in /usr/lib/bonobo/servers directory. When I manually compiled gnote with libpanelappletmm-2.6-dev installed the problem was solved.
Comment 9 Rahul Sundaram 2009-05-05 14:28:57 EDT
That's a different issue. You can easily confirm that it is not a identical problem with rpm -ql gnote and running ldd on /usr/bin/gnote
Comment 10 Fedora Update System 2009-05-06 00:06:06 EDT
gnote-0.3.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnote-0.3.1-1.fc10
Comment 11 You 2009-05-08 09:41:48 EDT
This bug has been fixed in the gnote-0.3.1 rpm that is available now.
Comment 12 Rahul Sundaram 2009-05-08 10:17:32 EDT
Thanks for confirming
Comment 13 Fedora Update System 2009-05-09 00:25:42 EDT
gnote-0.3.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.