Bug 498743 - Symbolic links left in /tmp (minor cleanup)
Symbolic links left in /tmp (minor cleanup)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 13:34 EDT by Tom London
Modified: 2009-07-22 18:07 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.8-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:07:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-05-02 13:34:58 EDT
Description of problem:
Notice files like those below "hanging around" in /tmp:

lrwxrwxrwx. 1 tbl  tbl      34 2009-04-25 11:08 49f3518a1d219 -> /etc/cups/ppd/HP-LaserJet-5MP2.ppd
lrwxrwxrwx. 1 tbl  tbl      34 2009-05-01 16:56 49fb8c3cb1e04 -> /etc/cups/ppd/KyoceraFS-CN5030.ppd

Not sure who creates them, but shouldn't they clean up after themselves?

Appears that the names selected will not get "cleaned up" on reboots.

Version-Release number of selected component (if applicable):
cups-libs-1.4-0.b2.15.fc11.x86_64
cups-1.4-0.b2.15.fc11.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2009-05-12 10:08:41 EDT
Fixed upstream in commit 6b828a8.  Thanks for the report.
Comment 2 Bug Zapper 2009-06-09 11:01:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2009-06-18 13:03:00 EDT
system-config-printer-1.1.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.8-1.fc11
Comment 4 Tom London 2009-06-18 17:16:17 EDT
I'm running Rawhide now.

Can I test this with the fc12 package?
Comment 5 Tim Waugh 2009-06-18 17:41:06 EDT
Yes, 1.1.8-1.fc12.
Comment 6 Fedora Update System 2009-06-19 09:46:29 EDT
system-config-printer-1.1.8-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6777
Comment 7 Tom London 2009-06-22 14:00:23 EDT
I believe I'm still seeing files in /tmp.

I'm running system-config-printer-1.1.8-1.fc12.x86_64.

[root@tlondon ~]# ls -l /tmp/4*
lrwxrwxrwx. 1 root root 33 2009-06-21 16:33 /tmp/4a3ec32fcb0d5 -> /etc/cups/ppd/HP-LaserJet-5MP.ppd
lrwxrwxrwx. 1 root root 34 2009-06-22 08:31 /tmp/4a3fa3ba0f332 -> /etc/cups/ppd/hp-LaserJet-1300.ppd
[root@tlondon ~]#
Comment 8 Tim Waugh 2009-06-23 06:54:54 EDT
These symlinks may be made by another application using the libcups API but not cleaning up after itself.  Are you able to determine a sequence of steps that will cause one of these symlinks to be left around after using system-config-printer and exiting it?
Comment 9 Tom London 2009-06-23 09:26:57 EDT
Sigh.  After removing the /tmp/4* files, my first attempts to reproduce failed.

I'll probe more later today.

If I can't reproduce, I'll chalk this up to strangeness on my part.
Comment 10 Fedora Update System 2009-06-30 17:23:33 EDT
system-config-printer-1.1.8-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6777
Comment 11 Fedora Update System 2009-07-11 13:10:24 EDT
system-config-printer-1.1.8-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-07-20 05:24:07 EDT
system-config-printer-1.1.8-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.8-6.fc11
Comment 13 Fedora Update System 2009-07-22 18:06:24 EDT
system-config-printer-1.1.8-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.