This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 498747 - Sound too low
Sound too low
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 14:06 EDT by Bruno Antunes
Modified: 2009-06-29 08:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 08:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info output (17.60 KB, text/plain)
2009-05-06 18:31 EDT, Bruno Antunes
no flags Details

  None (edit)
Description Bruno Antunes 2009-05-02 14:06:19 EDT
Description of problem:
Maximum volume is barely hearable

Version-Release number of selected component (if applicable):
Rawhide (installed the Preview CD to disc)

How reproducible:
Bootup, play some sound or something and even at 100% volume, it's barely hearable
  
Actual results:
Low sound

Expected results:
100% should be pretty loud

Additional info:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Acer Incorporated [ALI] Device 015e
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at f0400000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Comment 1 Lennart Poettering 2009-05-05 12:13:51 EDT
Please follow the suggestions here:

http://forums.fedoraforum.org/showpost.php?p=1206905&postcount=14

And include the alsa-info.sh and amixer output here.
Comment 2 Bruno Antunes 2009-05-06 05:01:22 EDT
Will do tonight, when I get home!
Comment 3 Bruno Antunes 2009-05-06 18:31:12 EDT
Created attachment 342747 [details]
alsa-info output

I ran alsa-info and it said there was a new version available and downloaded it to /tmp. I re-ran it and got this output under /tmp/alsa-info.u5v1RqI7Ti/alsa-info.txt
Comment 4 Bruno Antunes 2009-05-06 18:32:41 EDT
amixer output:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 32761 [50%] [on]
  Front Right: Capture 32761 [50%] [on]


My sound-card is 5.1 (or should be, there's a "sub-woofer" on the laptop) but I seem to only get sound on two channels... :!
Comment 5 Bruno Antunes 2009-05-06 18:34:07 EDT
As for the tip in the forum, here's the output from running alsactl init as root:

Unknown hardware: "HDA-Intel" "Nvidia MCP78 HDMI" "HDA:10ec0888,1025015e,00100202 HDA:14f12c06,1025015e,00100000 HDA:10de0006,10de0101,00100000" "" ""
Hardware is initialized using a guess method
Comment 6 Bruno Antunes 2009-05-06 18:39:49 EDT
One last thing - running "alsamixer -c 0" as root on the terminal shows a WHOLE LOT of other sound controls and I can now boost the volume to acceptable levels! :D How can I make this default in Gnome?
Comment 7 Bruno Antunes 2009-05-06 18:44:13 EDT
Sorry for not putting this all together :S but one more thing:

running 

speaker-test -c 5  -t wav

I can hear all channels... but if my soundcard is 5.1, -c 6 should work, right? But alas, no sound from the "LFE" channel is heard if I run the test with -c 6 :(
Comment 8 Lennart Poettering 2009-05-06 21:34:56 EDT
Uh, that amixer output is not from amixer -c0. Please do as suggested in the references article: please get me the output of "amixer -c0" before and after you used "alsamixer -c0" to make the card work.
Comment 9 Bruno Antunes 2009-05-07 05:24:35 EDT
Alas, I'm boned. I updated the kernel and Nouveau driver when I booted my machine last night and now I can't reboot into X ... :| I have to start single mode and try this again, will get back to you soon.
Comment 10 Bug Zapper 2009-06-09 11:01:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jim McElwaine 2009-06-15 13:46:22 EDT
This is extremely poor behaviour by Fedora 11. Sound has worked very well for all the Fedora's up until 10 but was broken in 11 until I discovered
alsamixer -c 0 and the extra controls this shows. Sound playback worked but was very quiet. Sound recording didn't work at all and the pulseaudio documentation was completely unhelpful. After running alsamixer -c 0 I have now managed to turn on the internal microphone and boost the out levels to something sensible. It is a real shame that the necessary controls are completely hidden. I've used Redhat linux since 94 and this has been one of the toughest problems for me to fix becuase all the necessary information is hidden away and the interaction between pulseaudio and ALSA seems badly broken.
Comment 12 Lennart Poettering 2009-06-29 08:27:23 EDT
I am assuming this got fixed with the ALSA mixer db updates that made it into F11 final. Closing. Feel free to reopen if "alsactl init" does not fix this issue for good.

Note You need to log in before you can comment on or make changes to this bug.