Bug 498752 - No more "letters" pages with sqlite 3.6
No more "letters" pages with sqlite 3.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: repoview (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 16:17 EDT by Remi Collet
Modified: 2010-02-17 11:56 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.4-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 08:14:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repoview-substr.patch (472 bytes, patch)
2009-05-02 16:17 EDT, Remi Collet
no flags Details | Diff
Fix substr and order issues (992 bytes, patch)
2009-10-31 06:40 EDT, Remi Collet
no flags Details | Diff

  None (edit)
Description Remi Collet 2009-05-02 16:17:01 EDT
Created attachment 342196 [details]
repoview-substr.patch

Substr syntax have change in latest sqlite used in F11/rawhide

First character is 1, and 0 is now undefined

---- simple script run in EL5
$ sqlite3
SQLite version 3.3.6
sqlite> select substr('ABC',1,1);
A
sqlite> select substr('ABC',0,1);
A

---- simple script run in F11
$ sqlite3
SQLite version 3.6.12
sqlite> select substr('ABC',1,1);
A
sqlite> select substr('ABC',0,1);

(latest return an empty string)

As repoview use 0 to find the first letter, this fail.

Simple/trivial patch attached solves the issue
Comment 1 Bug Zapper 2009-06-09 11:02:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Remi Collet 2009-10-26 14:06:10 EDT
Please F12 is also affected...
Comment 3 Johan Cwiklinski 2009-10-26 14:12:04 EDT
I confirm the bug, and I confirm the trivial patch fixes it.

Maybe this could be fixed quickly? Seems that the issue is always present aloso for F-12 (and probably rawhide).
Comment 4 Remi Collet 2009-10-31 06:40:33 EDT
Created attachment 366911 [details]
Fix substr and order issues

I found another bug.

If the repository contains various versions of the same package, latest list is not correct

New attached patch fixes both issues.
Comment 5 Fedora Update System 2010-01-27 22:01:16 EST
repoview-0.6.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/repoview-0.6.4-1.fc11
Comment 6 Fedora Update System 2010-01-27 22:01:26 EST
repoview-0.6.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/repoview-0.6.4-1.fc12
Comment 7 Fedora Update System 2010-01-27 22:01:35 EST
repoview-0.6.4-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/repoview-0.6.4-1.el5
Comment 8 Fedora Update System 2010-01-28 16:15:31 EST
repoview-0.6.4-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update repoview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-0142
Comment 9 Fedora Update System 2010-01-28 22:23:40 EST
repoview-0.6.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update repoview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1182
Comment 10 Fedora Update System 2010-01-28 22:26:20 EST
repoview-0.6.4-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update repoview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1198
Comment 11 Fedora Update System 2010-02-16 08:13:58 EST
repoview-0.6.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-02-16 08:20:08 EST
repoview-0.6.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-02-17 11:56:49 EST
repoview-0.6.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.