This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 498761 - Fedora-11-Preview-x86_64-DVD.iso crashes at isolinux printf
Fedora-11-Preview-x86_64-DVD.iso crashes at isolinux printf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 22:12 EDT by Wolfgang Rupprecht
Modified: 2009-05-06 13:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 13:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2009-05-02 22:12:05 EDT
Description of problem:

Fedora-11-Preview-x86_64-DVD.iso crash at isolinux printf.
Observed on 2 different systems and using 2 different dvd discs.
Tested on a Compaq v5000 laptop, Tyan s2865.desktop

Sometimes it would hang before printing the isolinux printf, other times it would print it and something that looked like a bios FD error, other times it would display the graphical screen for the install choices and hang as soon as I selected "1".  When it fails after the isolinux printf this is what I see:

isolinux: Disk error 80, AX = 422B, drive 9F

Boot failed: press a key to retry...

I often have to press the reset button to get it unwedged.  Pressing the reset button after the hang will *power down* the system (weird!).

Version-Release number of selected component (if applicable):

Fedora-11-Preview-x86_64-DVD.iso

How reproducible:

always

Steps to Reproduce:
1. insert disc
2. hit power button to turn on
3. watch it hang
  
Actual results:

hang

Expected results:

no hang.

Additional info:

This is the checksum I see when running "sha256sum Fedora-11-Preview-x86_64-DVD.iso".  Copied here in case the repository had an incorrect/hacked iso version.

a51baab45ab7f17d5fde963a7f0223145b9429861a1c6a18a9aab392be23d741  Fedora-11-Preview-x86_64-DVD.iso
Comment 1 Wolfgang Rupprecht 2009-05-02 22:16:55 EDT
I forgot to mention, the dvd disc was a dvd+rw burned with "growisofs -Z /dev/dvd=Fedora-11-Preview-x86_64-DVD.iso"
Comment 2 Jeremy Katz 2009-05-04 09:20:15 EDT
Can you try reburning at a slower speed?  This looks like a possible burn error/bad disc.
Comment 3 Wolfgang Rupprecht 2009-05-04 09:50:30 EDT
burning slower is proving problematic.  Growisofs seems to be ignoring the "-speed=1" arg.  Ideas?   Is there s simple way to do a sha256sum of the raw dvd? The obvious method "sha256sum /dev/dvd" fails after a few minutes with an error.

Appended is the growisofs output where I tried to burn at 1x.  Notice the software is claiming a speed of 4.1x.

$ /tmp/burn_dvd_slow Fedora-11-Preview-x86_64-DVD.iso 
+ '[' 1 '!=' 1 ']'
+ ISO=Fedora-11-Preview-x86_64-DVD.iso
+ RAWCD=/dev/dvd
+ eject -t cdrom
+ growisofs -speed=1 -Z /dev/dvd=Fedora-11-Preview-x86_64-DVD.iso
WARNING: /dev/dvd already carries isofs!
About to execute 'builtin_dd if=Fedora-11-Preview-x86_64-DVD.iso of=/dev/dvd obs=32k seek=0'
/dev/dvd: "Current Write Speed" is 4.1x1352KBps.
   28016640/4610678784 ( 0.6%) @4.1x, remaining 16:21 RBU 100.0% UBU   2.3%
   46792704/4610678784 ( 1.0%) @4.1x, remaining 16:15 RBU 100.0% UBU 100.0%
   65568768/4610678784 ( 1.4%) @4.1x, remaining 15:01 RBU 100.0% UBU 100.0%
   84344832/4610678784 ( 1.8%) @4.1x, remaining 14:18 RBU 100.0% UBU 100.0%
  103153664/4610678784 ( 2.2%) @4.1x, remaining 14:33 RBU 100.0% UBU 100.0%
  121929728/4610678784 ( 2.6%) @4.1x, remaining 14:06 RBU  98.4% UBU 100.0%
  140705792/4610678784 ( 3.1%) @4.1x, remaining 13:45 RBU 100.0% UBU 100.0%
  159481856/4610678784 ( 3.5%) @4.1x, remaining 13:57 RBU  99.8% UBU 100.0%
Comment 4 James Laska 2009-05-04 10:12:42 EDT
Wolfgang, are you able to rule out media/writer issues?  Do you have a qemu/kvm guest you can boot this DVD in?  If it boots under a qemu/kvm guest that will help identify whether the issue is with the DVD itself or the media/writer.

Thanks,!
James
Comment 5 Wolfgang Rupprecht 2009-05-04 11:50:26 EDT
James, sorry, no qemu experience yet.

I did manage to read the data off the dvd and it appears to be a good bit-for-bit copy.  Here is what I needed to do (and I can't believe there isn't an easier way to verify a dvd burn).

 
    # time dd if=/dev/sr0 of=FromDVD.iso ibs=2048
    2295104+0 records in
    9180416+0 records out
    4700372992 bytes (4.7 GB) copied, 1713.62 s, 2.7 MB/s

    real	28m33.713s
    user	0m3.656s
    sys	1m21.668s

This copied the full 4.7 Gigs that the dvd could hold, not the actual populated amount of the disc.  I had to trim it to actual iso size of 4610678784 bytes.

(/ 4610678784.0 2048) 2251308.0

    $ dd if=FromDVD.iso of=FromDVD-Trimmed.iso ibs=2048 count=2251308
    2251308+0 records in
    9005232+0 records out
    4610678784 bytes (4.6 GB) copied, 99.6781 s, 46.3 MB/s
    $ cmp FromDVD-Trimmed.iso Fedora-11-Preview-x86_64-DVD.iso 
    $

So it does look like at least the source system can read back the dvd correctly.
I'll re-run the test on one of the target systems in case the disc is borderline in some drive-specific way.
Comment 6 Wolfgang Rupprecht 2009-05-04 14:49:55 EDT
There is indeed a drive-specific error here.  Both target systems while running fedora-10 can't read the fedora-11-preview disc created on the source system also running fedora-10. Furthermore, a preview disc created on the tyan target system can't be read back if burned with the fedora-11-preview iso.

After much experimenting, it appears that on my systems, growisofs running on fedora-10 only reliably writes to pristine media.   If I write to pre-used erasable media then some drives can read it and others can't.  This happens even when I write the disc on one of the target systems.  I wonder if some state on the pre-used disc isn't being cleared correctly.
Comment 7 Wolfgang Rupprecht 2009-05-05 14:26:12 EDT
this isn't an isolinux problem.  Feel free to close.

(at most it is a tools problem where there needs to be a better way to test dvd's for good/bad burns from the command line.)

Note You need to log in before you can comment on or make changes to this bug.