Bug 498767 - createrepo doesn't honour --checksum option
createrepo doesn't honour --checksum option
Status: CLOSED DUPLICATE of bug 494951
Product: Fedora
Classification: Fedora
Component: createrepo (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 04:08 EDT by Remi Collet
Modified: 2016-09-19 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 10:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
createrepo-checksum.patch (665 bytes, patch)
2009-05-03 10:19 EDT, Remi Collet
no flags Details | Diff

  None (edit)
Description Remi Collet 2009-05-03 04:08:25 EDT
When trying to generate metadata for an older Fedora version from F-11 using createrepo-0.9.7-6.fc11 with

createrepo --checksum sha --database .

In the repomd.xml checksum are sha : ok

<checksum type="sha">7075fceb5a9c8a9dcde06a6234ee49aa0eaf789b</checksum>

But in the primary.xml.gz, sha256 still used

<checksum type="sha256" pkgid="YES">75954e069e8eb547633d4e4561e220ba5bdcc7ae22f7405b48b88d8238238bc3</checksum>

The medata generated are unusable (as older yum can't check this checksum)
Comment 1 Remi Collet 2009-05-03 10:19:09 EDT
Created attachment 342233 [details]
createrepo-checksum.patch

Issue seems from yum as yumbased.CreateRepoPackage set sha256 as default checksum type.

Here is a simple hack in createrepo which seems to work without changing yum lib.

I hope this will help.
Comment 2 seth vidal 2009-05-04 10:28:26 EDT
ultimately the same as 494951

and fixed at the same time.

*** This bug has been marked as a duplicate of bug 494951 ***

Note You need to log in before you can comment on or make changes to this bug.