Bug 498769 - [2.6.29] Warning when unloading iwl3945
[2.6.29] Warning when unloading iwl3945
Status: CLOSED DUPLICATE of bug 499811
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 04:13 EDT by Georgi Hristozov
Modified: 2009-07-08 13:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 13:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georgi Hristozov 2009-05-03 04:13:37 EDT
Description of problem:
Unloading iwl3945 leads to a kernel panic.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29.2-52.fc10.i686

How reproducible:
Always.

Steps to Reproduce:
1. Boot kernel-PAE-2.6.29.2-52.fc10.i686
2. rmmod iwl3945
  
Actual results:
Kernel panic.

Expected results:
Successful unload of the module.

Additional info:
The problem exists with kernel-PAE-2.6.29.2-48.rc1.fc10.i686. kernel-PAE-2.6.27.21-170.2.56.fc10.i686 seems to be OK.
Comment 1 Georgi Hristozov 2009-05-03 04:52:19 EDT
Here's the oops:

WARNING: at lib/debugobjects.c:217 debug_print_object+0x42/0x50() (Not tainted)
Hardware name: Satellite A200
ODEBUG: free active object type: timer_list
Modules linked in: i915 drm i2c_algo_bit aes_i586 aes_generic mmc_block omnibook rfcomm bridge stp bnep sco l2cap ppdev parport_pc parport coretemp hwmon sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm arc4 ecb sdhci_pci snd_timer snd sdhci uvcvideo mmc_core soundcore iTCO_wdt i2c_i801 snd_page_alloc iTCO_vendor_support yenta_socket iwl3945(-) rsrc_nonstatic videodev i2c_core btusb v4l1_compat input_polldev joydev tifm_7xx1 tifm_core firewire_ohci video pcspkr output r8169 firewire_core mii mac80211 bluetooth crc_itu_t lib80211 cfg80211 [last unloaded: microcode]
Pid: 2472, comm: rmmod Not tainted 2.6.29.2-52.fc10.i686.PAEdebug #1
Call Trace:
[<c04352fd>] warn_slowpath+0x77/0xb3
[<c0452a75>] ? register_lock_class+0x17/0x290
[<c04537f5>] ? mark_lock+0x1e/0x349
[<c04537f5>] ? mark_lock+0x1e/0x349
[<c04537f5>] ? mark_lock+0x1e/0x349
[<c054901d>] ? debug_check_no_obj_freed+0x6e/0x16d
[<c0548c63>] debug_print_object+0x42/0x50
[<c0549040>] debug_check_no_obj_freed+0x91/0x16d
[<c0486fe1>] __free_pages_ok+0x147/0x154
[<c0487006>] free_compound_page+0x18/0x1a
[<c048a25b>] put_page+0x37/0xa3
[<c04a690b>] kfree+0x46/0x105
[<f81291cd>] cfg80211_dev_free+0x1d/0x20 [cfg80211]
[<f812982c>] wiphy_dev_release+0xd/0xf [cfg80211]
[<c05d1829>] device_release+0x34/0x52
[<c0540589>] kobject_release+0x40/0x50
[<c0540549>] ? kobject_release+0x0/0x50
[<c0541034>] kref_put+0x3c/0x4a
[<c05404c5>] kobject_put+0x37/0x3c
[<c05d1321>] put_device+0xf/0x11
[<f81291ae>] wiphy_free+0xb/0xd [cfg80211]
[<f82480a6>] ieee80211_free_hw+0xb/0xd [mac80211]
[<f82e0589>] iwl3945_pci_remove+0x281/0x289 [iwl3945]
[<c055157c>] pci_device_remove+0x19/0x39
[<c05d3807>] __device_release_driver+0x63/0x80
[<c05d3894>] driver_detach+0x70/0x94
[<c05d2e0e>] bus_remove_driver+0x63/0x89
[<c05d3c49>] driver_unregister+0x2a/0x2e
[<c055176b>] pci_unregister_driver+0x21/0x60
[<f82e0301>] iwl3945_exit+0x1c/0x23 [iwl3945]
[<c045d0ce>] sys_delete_module+0x1ab/0x206
[<c0452653>] ? lock_release_holdtime+0x30/0x131
[<c04b2c54>] ? path_put+0x15/0x18
[<c04091ce>] ? restore_nocheck_notrace+0x0/0xe
[<c040906b>] sysenter_do_call+0x12/0x3f
---[ end trace efa136f745047200 ]---
Comment 2 Georgi Hristozov 2009-05-13 11:02:50 EDT
The bug is reproducible on 2.6.29.2-126.fc11.i686.PAE.
Comment 3 Stéphane Lesimple 2009-05-13 16:43:32 EDT
Just for information, Bug #499811 is probably the same as this one, but for Fedora 10 kernels.
Comment 4 John W. Linville 2009-07-08 13:36:06 EDT

*** This bug has been marked as a duplicate of bug 499811 ***

Note You need to log in before you can comment on or make changes to this bug.