Bug 498784 - Resume from suspend not working on X1400 based ThinkPad T60
Resume from suspend not working on X1400 based ThinkPad T60
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 06:46 EDT by Amit Shah
Modified: 2009-10-13 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 12:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (243.68 KB, text/plain)
2009-05-03 06:46 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2009-05-03 06:46:54 EDT
Created attachment 342218 [details]
Xorg.0.log

Description of problem:

I have a ThinkPad T60 that has the X1400 chip; smolt profile at

http://www.smolts.org/client/show/pub_d90059cb-3258-4417-b624-114fc67f6ddc

Trying out the KDE F11-pr release. Suspend works fine but resume doesn't. I get a garbled display and the system doesn't respond to keyboard / mouse. The caps lock stays in the 'on' state.

When I try this with nomodeset=1 from the liveusb, just the desktop wallpaper is seen. The mouse pointer moves according to input and I can toggle the caps lock as well. However, after some time, the caps lock LED starts blinking and control over the mouse and keyboard is lost.

The actual desktop isn't seen in either of the modes after resume.

Attaching Xorg.0.log from a freshly-booted system with KMS enabled.
Comment 1 Bug Zapper 2009-06-09 11:03:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Samuel Sieb 2009-07-13 01:22:47 EDT
If the caps lock is blinking, there must be a kernel panic.  Can you check /var/log/messages for possible dump info?
Comment 3 Tim Niemueller 2009-07-29 06:16:42 EDT
I'm seeing the same. The caps lock is not blinking. I only get vertical colored lines and can't do anything. It seems not to react to key presses anymore, e.g. pressing Fn-F4 for another sleep does not work.

Smolt profile is at http://www.smolts.org/client/show/pub_d3521300-de3d-40ee-be30-5c99bb593c3b
Comment 4 Tim Niemueller 2009-09-29 06:16:29 EDT
Haven't seen this in a while, so the problem seems to be fixed.
Comment 5 Jérôme Glisse 2009-10-13 11:31:13 EDT
So does it works now for the reporter ? If so please close the bug, if not please try Fedora 12 test livecd https://fedoraproject.org/get-prerelease
Comment 6 Amit Shah 2009-10-13 12:32:06 EDT
I'll open a new bug in case this persists with F12. Closing this for now.

Note You need to log in before you can comment on or make changes to this bug.