Bug 498818 - The scrolling is not enabled on the touchpad even after setting the preferences
The scrolling is not enabled on the touchpad even after setting the preferences
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-03 12:17 EDT by Victor Bogado
Modified: 2010-06-28 08:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 08:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output from synclient -m 20 while attempting to scroll on the right edge. (6.38 KB, text/plain)
2009-05-05 02:17 EDT, Jacob Masaki
no flags Details

  None (edit)
Description Victor Bogado 2009-05-03 12:17:11 EDT
Description of problem:
After enabling the scrolling on the inspiron 1525 the touchpad still does not work as scroll.

Version-Release number of selected component (if applicable):

How reproducible:
As far as I know every time
Comment 1 Victor Bogado 2009-05-03 12:56:15 EDT
the configuration on this page (http://wiki.archlinux.org/index.php/Dell_Inspiron_1525#Synaptics) works for the "edge" style of scrolling, but still no luck with the two fingers. I am not sure if the hardware on this computer supports this :(.
Comment 2 Jacob Masaki 2009-05-03 16:46:16 EDT
I am experiencing the same issue with the Dell Inspiron 1420, I have not tried using a .fdi to set the scrolling values.  

I expect that the problem is with where the right edge of the Touchpad is defined in f11, though I am not sure.  

Under Fedora 10 to get things working properly, I need to use a .fdi or tweak my xorg to get the touchpad to do sane things.  

With the F11 preview toggling "tap to click" on and off in the touchpad preferences appears to work, so it looks like the OS does recognize the touchpad as a touchpad, and is loading the synaptics driver.  

The default speed is a little bit off, too.  

I feel like both of these problems could be due to the dimensions being set wrong in xorg/hal, not sure though.  Actually, if it thought the touchpad was larger than it is, it would likely make the mouse move slower, huh?  

Oh well.  Changing the acceleration and such works fine in the menu, but it would make some sense to look at the defaults for the touchpads Inspirons.  

I'm running F10 as my normal install, though I can boot F11 off of a flash drive if you need information from F11 that can't be gained from F10.
Comment 3 Matthias Clasen 2009-05-03 16:51:29 EDT
Peter, any idea ?
Comment 4 Peter Hutterer 2009-05-04 08:03:44 EDT
Please check your Xorg.log for the line "left right middle" during the synaptics initialization. Does the same line state double and triple too? If not, your hardware doesn't support two-finger scrolling.

please enable SHMconfig in the configuration (either xorg.conf if you have any or in the fdi file) and run synclient -m 20. Then move the finger to the right edge of the touchpad and check the values.

Then check the values with those reported by synclient -m and those reported in the Xorg.log. Some touchpads report a larger range than they actually report, and this screws up the edge calculation.

Please do all this in F-11.
Comment 5 Jacob Masaki 2009-05-05 02:17:22 EDT
Created attachment 342414 [details]
Output from synclient -m 20 while attempting to scroll on the right edge.  

Enabling shmconfig was a little tricky, I edited /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi to add the line <merge key="input.x11_options.SHMConfig" type="string">true</merge>

However, when I put it after <match key="info.capabilities" contains="input.touchpad"> as someone mentioned on another bugzilla post (I just googled quickly to find how to enable shmconfig, and didn't save the link) it didn't work.  

I had to bypass the test, and just have it merge unconditionally, which leads me to suspect that the touchpad isn't being detected as a touchpad.  

Though, "tap-to-click" and "disable while typing" both appear to work, so perhaps the problem was something else.
Comment 6 Peter Hutterer 2009-05-05 19:03:36 EDT
You seem to have a ALPS touchpad, and scrolling was a bit broken on those. 
Fixed with xorg-x11-drv-synaptics-1.1.0-5.

Please try this version, if it's still broken I need your Xorg.log and the output of lshal.
Comment 7 Jacob Masaki 2009-05-13 21:11:44 EDT
The version you linked to makes scrolling work, but it doesn't look to be enabled by installing the RPM automatically.  (This might be because the account locked the setting in the first time I logged in, though, I updated the xorg package.)  

Also, the cursor seems to move a little quickly to be usable.  

Both of these can be fixed quite easily by using the mouse configuration program, but I feel like they shouldn't *need* to be.  

Okay, this is a little off topic, but are there plans to go back to the sub-menus like "Hardware" and such for the Fedora 11 final release, or are those gone for good?  It made finding the mouse settings harder.
Comment 8 Matthias Clasen 2009-05-13 21:20:17 EDT
No, we are not going back to the submenus by default. 
But if you want them back, you can just install the preferences-menus package.
Comment 9 Victor Bogado 2009-05-14 16:45:18 EDT
I guess that the version 1.1.0-5 (current now on F11) is working even after I removed the work-around file I had installed. As for the two fingers, I thought that even though the hardware does not support this directly the software did an emulation of the feature. 

I checked the X11 log, and indeed the hardware does not support either double nor triple. Too bad, for I think that scrolling with multiple fingers better then the edge scrolling.
Comment 10 Peter Hutterer 2009-05-14 18:43:31 EDT
(In reply to comment #7)
> The version you linked to makes scrolling work, but it doesn't look to be
> enabled by installing the RPM automatically. 

it's enabled in the driver but upon login gnome-settings-daemon applies the default settings if you haven't configured it (and default is disabled). A fix for this is in the pipe.

Comment 11 Bug Zapper 2009-06-09 11:04:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 12 Bug Zapper 2010-04-27 10:05:46 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 13 Bug Zapper 2010-06-28 08:21:00 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.