Bug 498820 - Anaconda crashes while tying to create custom partition layout
Anaconda crashes while tying to create custom partition layout
Status: CLOSED DUPLICATE of bug 500808
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 12:26 EDT by Valent Turkovic
Modified: 2009-05-29 11:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 11:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2009-05-03 12:26:57 EDT
Description of problem:
I tried to create custom partition layout (delete some existing partitions and create new ones in free space).

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. delete any partition to create free space
2. try to create custion partition layout with separate /boot / and /home partitions
3. fail :(
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2009-05-03 14:19:43 EDT
I had trouble attaching my crash report so here is the link to it:
http://dl.getdropbox.com/u/184632/anaconda_crash.txt
Comment 2 Peter Robinson 2009-05-04 07:49:05 EDT
I think this is the same thing I was seeing with custom partitions. I reported a bug which was DUPED to bug 495156
Comment 3 James Laska 2009-05-04 08:24:15 EDT
Attaching shortened version of traceback included in comment#1 for easier searching

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 700, in _removeDevice
    "Logical partitions present." % dev.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 736, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 645, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/anaconda/partIntfHelpers.py", line 165, in doDeleteDependentDevices
    storage.destroyDevice(dep)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 974, in deleteCB
    device):
ValueError: Cannot remove extended partition sda4.  Logical partitions present.
Comment 4 Chris Lumens 2009-05-29 11:14:28 EDT
Forward duping this bug to one that was tracking this specific problem with that error message in the title.  Thanks for the bug report.

*** This bug has been marked as a duplicate of bug 500808 ***

Note You need to log in before you can comment on or make changes to this bug.