Bug 498832 - bgpd crashes on as paths containing more 6 digit as numbers
bgpd crashes on as paths containing more 6 digit as numbers
Status: CLOSED DUPLICATE of bug 499033
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 14:42 EDT by Dušan Hokův
Modified: 2014-11-09 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 09:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dušan Hokův 2009-05-03 14:42:51 EDT
Description of problem:
bgpd crashes on as paths containing more 6 digit as numbers

Version-Release number of selected component (if applicable):
0.99.11

How reproducible:
use bgpd as border router

Steps to Reproduce:
1.run bgpd
2.import prefixes
3.
  
Actual results:
crash always

Expected results:
run

Additional info:
bug is also in quagga bugzilla:

http://bugzilla.quagga.net/show_bug.cgi?id=500

There is also patch:

--- quagga-0.99.11-orig/bgpd/bgp_aspath.c	2008-09-05 17:27:26.000000000 +0300
+++ quagga-0.99.11/bgpd/bgp_aspath.c	2009-05-03 19:06:55.000000000 +0300
@@ -549,7 +549,7 @@
    * With 32bit ASNs, this range will increase, but only worth changing
    * once there are significant numbers of ASN >= 100000
    */
-#define ASN_STR_LEN (5 + 1)
+#define ASN_STR_LEN (10 + 1)
   str_size = MAX (assegment_count_asns (seg, 0) * ASN_STR_LEN + 2 + 1,
                   ASPATH_STR_DEFAULT_LEN);
   str_buf = XMALLOC (MTYPE_AS_STR, str_size);
Comment 1 Jiri Skala 2009-05-05 10:38:24 EDT
The bug duplicates BZ #499033. There are remarks about side effects of this short hack (negative values). I don't see it fixed completely but the patch in the twins bug is a bit strange.

*** This bug has been marked as a duplicate of bug 499033 ***

Note You need to log in before you can comment on or make changes to this bug.