Bug 498856 - The "part" keyword in the kickstart file accepts an option named "--label" is ignored ?
The "part" keyword in the kickstart file accepts an option named "--label" i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 23:56 EDT by Srinivas Satyavarpu
Modified: 2010-10-23 05:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-11.1.2.196-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 06:56:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pass the label for existing devices. (501 bytes, patch)
2009-06-30 08:41 EDT, Wade Mealing
no flags Details | Diff

  None (edit)
Description Srinivas Satyavarpu 2009-05-03 23:56:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The "part" keyword in the kickstart file accepts an option named  "--label".  Its purpose is to be able to provide a label to apply to the  file system that is created on the partition (see the -L option of  tune2fs).  Unfortunately, the when one specifies a label using the  "--label" option, that label is not actually applied to the file system.
It appears as if the "--label" option (and its associated argument) is  silently ignored.  My expectation is that anaconda should apply the label (my first preference) or it should produce a parsing error sayin that "--label" is an unknown/unsupported option rather than just ignoring the option.
Comment 5 Wade Mealing 2009-06-30 08:41:57 EDT
Created attachment 349946 [details]
pass the label for existing devices.
Comment 6 Wade Mealing 2009-06-30 23:20:26 EDT
Posted to anaconda devel, got ack for 5.5
Comment 7 RHEL Product and Program Management 2009-09-25 13:44:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Alexander Todorov 2009-12-14 10:20:32 EST
Hi folks,
this looks like it's been fixed in RHEL5.4 My automated test case uses the following ks.cfg partitioning:

clearpart --all --initlabel 
part /boot --asprimary --fstype="ext3" --size=200 --bytes-per-inode=4096 --label=BOOT
part swap --fstype="swap" --recommended --bytes-per-inode=4096 --label=SWAP
part / --fstype="ext3" --grow --size=2048 --bytes-per-inode=4096 --label=ROOTPART

The result for the root partition is:
# tune2fs -l /dev/sdb1
Filesystem volume name:   ROOTPART
... skip ...

/etc/fstab has
LABEL=ROOTPART          /                       ext3    defaults        1 1

and blkid reports:
/dev/sdb1: LABEL="ROOTPART" UUID="9b48a783-858d-4bf1-88f9-e15842319c04" TYPE="ext3" 

What has been fixed exactly?
Comment 12 Alexander Todorov 2010-02-02 06:56:20 EST
This works in the current release. See comment #10 and comment #11.

Note You need to log in before you can comment on or make changes to this bug.