Bug 498867 - PolicyKit-gnome doesn't appear in Gnome after installation
PolicyKit-gnome doesn't appear in Gnome after installation
Status: CLOSED DUPLICATE of bug 484945
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 02:46 EDT by Hedayat Vatankhah
Modified: 2009-05-05 09:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 12:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2009-05-04 02:46:23 EDT
Description of problem:
I installed Fedora 11 preview from DVD, and selected both Gnome and KDE for installation. after installation, in Gnome, PolicyKit-kde appears instead of PolicyKit-gnome. 
Then, I removed PolicyKit-kde and tried something which required authentication and PolicyKit-gnome appeared. I installed PolicyKit-kde again, and PolicyKit-gnome still works in gnome. I've not checked KDE to see which one will appear.

How reproducible:
100% in my installation.

Steps to Reproduce:
1. Install Fedora 11 Preview. Select both KDE and GNOME for installation.
2. Login to GNOME, and try to install a package using PackageKit.
  
Actual results:
KDE front-end for PolicyKit appears to get the root password

Expected results:
A Gnome frontend should appear.

Additional info:
The problem will be fixed after removing and re-installing PolicyKit-kde.
Comment 1 Matthias Clasen 2009-05-04 12:27:50 EDT

*** This bug has been marked as a duplicate of bug 484945 ***
Comment 2 Kevin Kofler 2009-05-05 09:37:35 EDT
> I've not checked KDE to see which one will appear.

Also PolicyKit-gnome. :-(

Whatever D-Bus defaults to is what you'll get, no matter what desktop environment you are in. :-(

Note You need to log in before you can comment on or make changes to this bug.