Bug 498921 - Umbrello crashes when deleting attribute
Umbrello crashes when deleting attribute
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 09:45 EDT by Hans Kristian
Modified: 2009-05-05 12:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 09:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmi file that makes umbrello crash when deleting servers->ip (41.68 KB, application/octet-stream)
2009-05-04 09:46 EDT, Hans Kristian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 191398 None None None Never

  None (edit)
Description Hans Kristian 2009-05-04 09:45:01 EDT
Description of problem:
When deleting a attribute from a class, umbrello crashes without any error or console messages (tried launching it from a console window).

It crashes the instant I press the delete button.

I am making a little overview of a database schema.
The language has been set to postgresql.

The file attached is the file that makes it crash. I have not managed to reproduce the error by making a new file, but I have not done extensive testing.
The file was made using umbrello in current FC10.

Console warning messages while loading the .xmi files are below.
It says that some ids are already in use and that it should be fixed, however it says nothing about how this can be done. Also, this message does not appear in any form when running the program from the application menu like a regular user would.

(PS: It would be nice if somebody split umbrello into a separate package ;)


Version-Release number of selected component (if applicable):
kdesdk-4.2.2-2.fc11.x86_64

How reproducible:
Happens every time

Steps to Reproduce:
1. Open .xmi file
2. Right click on the servers class, enter properties.
3. Go to attributes
4. Select ip
5. Press delete
6. Umbrello is now gone
  

Additional info:
umbrello(32724): Attempt to use QAction "edit_undo" with KXMLGUIFactory! 
umbrello(32724): Attempt to use QAction "edit_redo" with KXMLGUIFactory! 
umbrello(32724) UMLListView::findView: returning 0 at UMLListView::findView 
umbrello(32724) UMLListView::findView: returning 0 at UMLListView::findView 
umbrello(32724): loadFromXMI(UMLRole): id  "mmwxHIXOHsAl"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "DhNyBr1bTYSo"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "VMhlDrUQWrNh"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "gOGAvjwwCHAJ"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "ULy0ALgrhwzc"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "ftXqAh9i6MLk"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "asEuIyXcwk3z"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "AybdYfX44957"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "D2d8me7vbgY7"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "L3BQCGVKjYko"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "OPhz4D6PGFnQ"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "UHiDpT0EERMD"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "oaX0zrEOKamY"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "EuAIjjOjMsxE"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "aoT5XamJGrf6"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "vYBthGGlyMlO"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "6nKl9Z7E7Ltd"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "dSt1BarurTEI"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "j9HSVRlRVVFW"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "USD9na350BD9"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "IigoBvKfLVp6"  is already in use!!! Please fix your XMI file. 
umbrello(32724): loadFromXMI(UMLRole): id  "4qC41PBXpVwd"  is already in use!!! Please fix your XMI file. 
umbrello(32724) UMLListView::findView: returning 0 at UMLListView::findView 
umbrello(32724) UMLListView::findView: returning 0 at UMLListView::findView 
KCrash: Application 'umbrello' crashing...
sock_file=/home/hk/.kde/socket-hk/kdeinit4__0
KCrash cannot reach kdeinit, launching directly.
KCrash failed to exec(), errno = 2
Comment 1 Hans Kristian 2009-05-04 09:46:04 EDT
Created attachment 342305 [details]
xmi file that makes umbrello crash when deleting servers->ip
Comment 2 Rex Dieter 2009-05-04 10:02:33 EDT
If you don't mind, please report to upstream kde projects @ bugs.kde.org.  If you do, please let us know the bug #, so we can continue to track the issue.

(I'll probably do so myself eventually, provided I can reproduce, but it will likely be awhile...)
Comment 3 Hans Kristian 2009-05-04 10:14:13 EDT
I would rather not register on yet another bug tracker, especially since I otherwise have no relation to kde outside of umbrello. And since I only meant to use umbrello in order to make a one-time "pretty" overhead presentation, I'm not likely to spend much of my lacking free time bothering about it.

Sorry, at least it's an honest answer. =/
Comment 4 Kevin Kofler 2009-05-05 09:18:17 EDT
You MUST report this on https://bugs.kde.org/ if you want to have any chance of getting this fixed. This needs to be addressed by the upstream developers. Registering takes a minute at most.

Sorry, at least it's an honest reply.
Comment 5 Kevin Kofler 2009-05-05 09:19:16 EDT
And the reason we don't just file the upstream bug ourselves is that upstream may need a way to contact you to ask you for further questions, so you need to be the reporter or CCed on the upstream bug. You need an account at bugs.kde.org for that anyway.
Comment 6 Kevin Kofler 2009-05-05 09:30:55 EDT
Nevermind, looks like it's already filed:
https://bugs.kde.org/show_bug.cgi?id=191398

At least the description matches. I can't compare the backtraces because you don't have any (which is really another bug, why did KCrash fail to execute drkonqi? Maybe you don't have kdebase-runtime installed? We should drag that in through the dependencies).
Comment 7 Hans Kristian 2009-05-05 12:28:04 EDT
Correct, I dont have any kdebase* packages installed. I am running gnome, so thats probably why I dont have that packages pulled in from anywhere else.

Thanks for looking into it.

Note You need to log in before you can comment on or make changes to this bug.