Bug 498924 - Nouveau hang when booting F11 Preview release live CD ((WW) NOUVEAU(0): NV50CheckWriteVClk() timed out.)
Nouveau hang when booting F11 Preview release live CD ((WW) NOUVEAU(0): NV50C...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 09:54 EDT by Mauri Korkeala
Modified: 2018-04-11 14:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 02:35:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (66.16 KB, text/plain)
2009-05-04 09:54 EDT, Mauri Korkeala
no flags Details
/var/log/messages (69.78 KB, text/plain)
2009-05-04 10:04 EDT, Mauri Korkeala
no flags Details

  None (edit)
Description Mauri Korkeala 2009-05-04 09:54:59 EDT
Created attachment 342306 [details]
Xorg.0.log

Description of problem:
Fedora 11 i686 Preview Release live CD blank screen on boot. Keyboard doesn't respond.
Bugs 495534 and 493363 might be related, but separate bugs were requested.
Setup is nVidia Corporation GeForce 8800 GT rev 162 with BenQ 24" monitor (1920x1200 resolution connected using DVI-cable)

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.12-31.20090421git47bb00f.fc11.i586

How reproducible:
Everytime.

Steps to Reproduce:
1. Boot F11 Preview Release Live CD

  
Actual results:
1. Screen blanks, keyboard not responsive.
 
Expected results:
1. Login screen is displayed.

Additional info:
Xorg.0.log got from the system using SSH.
Xorg logs show 
(WW) NOUVEAU(0): NV50CheckWriteVClk() timed out.
(II) NOUVEAU(0): A reboot is probably required now.
Comment 1 Mauri Korkeala 2009-05-04 10:03:41 EDT
top shows high CPU usage for X (system still accessible using ssh).  Xorg could also be killed leaving computer running with out display or keyboard.

PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
3453 root      19  -1  175m 6656 4124 R 99.9  0.3  27:15.69 X
Comment 2 Mauri Korkeala 2009-05-04 10:04:32 EDT
Created attachment 342308 [details]
/var/log/messages
Comment 3 Matěj Cepl 2009-05-15 20:16:32 EDT
Closing as duplicate of bug 498579. Please, read in bug 498579 comment 4 which additional information could be helpful in investigating this issue.

*** This bug has been marked as a duplicate of bug 498579 ***
Comment 4 Matěj Cepl 2009-05-15 20:40:14 EDT
No, it isn't duplicate. I forgot that we are currently not providing /usr/lib*/dri/nouveau* at all.

Could we get also /var/log/dmesg, please? But otherwise, ASSIGNING to developers.
Comment 5 Ben Skeggs 2009-05-26 18:40:03 EDT
Can you install -36 (should be the latest available if you install all updates) and grab me updated logs (/var/log/Xorg.0.log will be enough).  The output is a little confused in -31 which you used previously.

I'd also be interested in knowing whether kms works here (nouveau.modeset=1 on kernel commandline)

Thanks!
Comment 6 Mauri Korkeala 2009-06-07 07:46:02 EDT
Sorry it took so long to respond.

I haven't been able to test with the -36 version, as I don't have Live CD with updated version available. Creating F11 LiveCD from F10 installation wasn't that easy. And installation to empty HD failed a s I run into HPA issues which I were't at that time able to solve. 

Anyway, the good news is that the preview version (-31) worked out just fine when I enabled KMS (nouveau.modeset=1). This means that there is a workaround and I'll be able to install F11 once it's released.

I will test and report back the results for the official F11 version. However, I'm leaving out of country for three weeks, so it will take awhile.
Comment 7 Bug Zapper 2009-06-09 11:07:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Ben Skeggs 2009-08-23 23:14:44 EDT
Any update?
Comment 9 Mauri Korkeala 2009-08-24 02:35:12 EDT
Sorry, forgot to update this bug.

F11 Release version worked correctly with my GeForce 8800 GT. So for this card the problem was fixed before F11 release.

Note You need to log in before you can comment on or make changes to this bug.