Bug 498999 - CS 8.0 Beta -- Unable to preform a master key change over
CS 8.0 Beta -- Unable to preform a master key change over
Status: CLOSED NOTABUG
Product: Dogtag Certificate System
Classification: Community
Component: TPS (Show other bugs)
1.1
All Linux
low Severity high
: ---
: ---
Assigned To: Christina Fu
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-05-04 14:44 EDT by Sean Veale
Modified: 2015-01-04 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 10:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log and config files (24.53 KB, application/zip)
2009-05-04 14:44 EDT, Sean Veale
no flags Details

  None (edit)
Description Sean Veale 2009-05-04 14:44:23 EDT
Created attachment 342349 [details]
log and config files

Description of problem:

After preforming the key change over procedure documented in section 6.9.5 of the admin guide I'm unable to establish a secure channel between the card and tps. 

From the tps error log
[2009-04-30 17:31:28] 1435eb80 RA::ComputeSessionKey - Failed connecting to TKS after 3 retries
[2009-04-30 17:31:28] 1435eb80 RA_Processor::SetupSecureChannel - Failed to create a secure channel - potentially due to an RA/TKS key mismatch or differing RA/TKS key versions.
[2009-04-30 17:31:28] 1435eb80 RA_Processor::UpgradeApplet - channel creation failure

There is some doc bugs that I'll file as a separate report



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Follow 6.9.5 to preform a key changeover
2.Attempt to enroll a card
3.
  
Actual results:
Failed to create secured channel

Expected results:
Able to enroll the token

Additional info:

Using safenet 330J cards. 

Added tps debug/error log , tps and tks config files and the commands I sent to preform this process.
Comment 1 Sean Veale 2009-05-06 10:12:01 EDT
This was user error and is not a bug.

Sean

Note You need to log in before you can comment on or make changes to this bug.