Bug 499006 - (CVE-2009-1513) CVE-2009-1513 libmodplug: buffer overflow vulnerability
CVE-2009-1513 libmodplug: buffer overflow vulnerability
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On:
  Show dependency treegraph
Reported: 2009-05-04 15:04 EDT by Vincent Danen
Modified: 2011-05-03 05:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-05-03 05:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Vincent Danen 2009-05-04 15:04:06 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2009-1513 to
the following vulnerability:

Name: CVE-2009-1513
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1513
Assigned: 20090504
Reference: CONFIRM: http://modplug-xmms.git.sourceforge.net/git/gitweb.cgi?p=modplug-xmms;a=commitdiff;h=c4ebb701be6ee9a296a44fdac5a20b7739ff0595
Reference: CONFIRM: http://sourceforge.net/project/shownotes.php?release_id=678622&group_id=1275
Reference: CONFIRM: http://sourceforge.net/tracker/?func=detail&aid=2777467&group_id=1275&atid=301275
Reference: BID:34747
Reference: URL: http://www.securityfocus.com/bid/34747
Reference: OSVDB:54109
Reference: URL: http://osvdb.org/54109
Reference: SECUNIA:34927
Reference: URL: http://secunia.com/advisories/34927
Reference: VUPEN:ADV-2009-1200
Reference: URL: http://www.vupen.com/english/advisories/2009/1200

Buffer overflow in the PATinst function in src/load_pat.cpp in
libmodplug before 0.8.7 allows user-assisted remote attackers to cause
a denial of service and possibly execute arbitrary code via a long
instrument name.
Comment 1 Ville Skyttä 2009-05-04 18:24:00 EDT
F-9 and F-10 already have 0.8.7:

F-11 will have it as well:

EPEL-5 has it in testing, signers have been notified (but libmodplug needs a real EPEL maintainer):
Comment 2 Vincent Danen 2009-05-11 12:30:07 EDT
The version of libmodplug that is embedded in the gstreamer-plugins package for Red Hat Enterprise Linux 3 and 4 is version 0.7 which does not include support for PAT files and is thus not affected by this vulnerability.
Comment 3 Ville Skyttä 2011-05-03 04:16:16 EDT
I suppose this bug can be closed now?

Note You need to log in before you can comment on or make changes to this bug.