Bug 499027 - libvirt not changing context on connected virt_image_t ISO images
libvirt not changing context on connected virt_image_t ISO images
Status: CLOSED DUPLICATE of bug 493692
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 16:40 EDT by Paul W. Frields
Modified: 2009-05-05 04:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 04:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2009-05-04 16:40:28 EDT
libvirt-0.6.2-3.fc11.x86_64
virt-manager-0.7.0-4.fc11.x86_64

libvirt is not relabeling an ISO image in use on a virtual machine.  I copied an ISO file into /var/lib/libvirt/images, ran virt-manager as root, connected the ISO file to a VM guest, and powered on the guest.  When I hit F12 and chose to boot from CD-ROM, I was greeted with a series of SELinux AVC denials.

The existing context on the ISO image was (and still is): system_u:object_r:virt_image_t:s0

I'm told that virt_content_t or svirt_t would be more appropriate, and that virt_image_t is only for images at rest.  dwalsh kindly informed me that libvirt should be changing the context for these images.
Comment 1 Mark McLoughlin 2009-05-05 04:27:56 EDT
Thanks for the report. I'm pretty sure this is a duplicate of bug #493692

*** This bug has been marked as a duplicate of bug 493692 ***

Note You need to log in before you can comment on or make changes to this bug.