Bug 499061 - Video goes to blank; system still functional
Video goes to blank; system still functional
Status: CLOSED DUPLICATE of bug 508069
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 514271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 22:42 EDT by Drew O'Brien
Modified: 2009-10-26 08:20 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:22:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'lshw' output from affected hardware (16.10 KB, text/plain)
2009-05-04 22:42 EDT, Drew O'Brien
no flags Details
Xorg server log file (68.89 KB, text/plain)
2009-05-05 21:08 EDT, Drew O'Brien
no flags Details
UPDATED 'lshw' output from standard Live install (15.35 KB, text/plain)
2009-05-05 23:54 EDT, Drew O'Brien
no flags Details
UPDATED Xorg log (62.31 KB, text/plain)
2009-05-05 23:56 EDT, Drew O'Brien
no flags Details

  None (edit)
Description Drew O'Brien 2009-05-04 22:42:57 EDT
Created attachment 342406 [details]
'lshw' output from affected hardware

Description of problem: On my hardware, after roughly two minutes of the keyboard/mouse usage idle, the screen goes blank. I receive a no signal message from my monitor, however, audio continues as normal. Moving the mouse or pressing a button on the keyboard restores the video, and the system appears to function properly during the blank screen and afterwards. I do not have my monitor set to sleep or lock in either my screensaver or power settings within GNOME.


Version-Release number of selected component (if applicable): Release 10.93 (Leonidas) Kernel 2.6.29.1-111.fc11.x86_64


How reproducible: Can be reproduced on my machine easily. Do not touch the keyboard or mouse for roughly two minutes and display will blank.


Steps to Reproduce:
1. Boot to desktop
2. Configure no lock/screensaver and no monitor sleep with GNOME utilities
3. Allow mouse and keyboard to be idle
4. Wait for roughly two minutes
  
Actual results: Video signal is lost by monitor.


Expected results: Video signal remains on.


Additional info: Output from 'lshw' attached to bug report for hardware specifics.
Comment 1 Matěj Cepl 2009-05-05 17:52:14 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Drew O'Brien 2009-05-05 21:08:15 EDT
Created attachment 342568 [details]
Xorg server log file
Comment 3 Drew O'Brien 2009-05-05 21:13:31 EDT
I've attached my X server log file.  I don't have a traditional xorg.conf, I am guessing due to the recent changes in X management. 

Also, I have done some further testing on my system.  I installed Fedora 11 Preview from the DVD, personally selecting packages, and using the Rawhide server through anaconda.  Today, I've reinstalled my system to the same specifications as I had prior: the results are the same.  The bug still exists as originally stated on the new install.

In my package selection, I did not install 'gnome-screensaver'; I figured that since I didn't want a screensaver or the ability for it, that I could not install that package.  This may very well be the culprit.  I am going to try: (a) to install the package into my current install; (b) install a new system with 'gnome-screensaver' included.

The original bug report I see now didn't address this issue which is a fault on my end (unless it should be considered as a dependency).  I will comment back once I've completed more testing.  If I can include any more information or system kickback for you, let me know.
Comment 4 Drew O'Brien 2009-05-05 21:40:30 EDT
Installing 'gnome-screensaver' from yum did not affect the problem.  I am going to continue to eliminate options by downloading and installing a system using the Live CD Preview which should ship with preselects for out of the box experience.  Will comment back the results.
Comment 5 Drew O'Brien 2009-05-05 23:54:44 EDT
Created attachment 342587 [details]
UPDATED 'lshw' output from standard Live install

This 'lshw' dump is updated from the original.  I doubt anything has changed, but I thought it prudent to attach updated logs to reflect a standard Fedora 11 Live CD x86-64 install.  The originals were based on a custom install from the DVD/anaconda installer.
Comment 6 Drew O'Brien 2009-05-05 23:56:28 EDT
Created attachment 342588 [details]
UPDATED Xorg log

This Xorg log is representative of a fully-updated (as of this post) Fedora 11 install from the x86-64 Live CD.  The original bug is still present, though this log file represents a standard install rather than a custom install through anaconda.
Comment 7 Drew O'Brien 2009-05-06 00:00:42 EDT
Final notes on today's testing:

(1) Original bug affects custom anaconda installs that do not include 'gnome-screensaver'

(2) Original bug affects custom anaconda installs that do include 'gnome-screensaver'

(3) Original bug affects standard install from Fedora 11 Preview Live CD (64-bit edition).

Hopefully this information can help.  I've exhausted all of my resources in pinning down an error on my part or a slipup somewhere in the system.  I will stay interested in this bug report, please let me know if I can be of additional help.  NOTE: The two loudly-spoken updated log files represent a standard GNOME Live 64-bit install; they are exempt from error in my package selection on a custom anaconda install.  

The issue still presents the same behavior and is still replicable as the original bug report noted.
Comment 8 Bug Zapper 2009-06-09 11:09:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Stefan Ring 2009-06-25 04:18:18 EDT
Does the screen turn back on when you move the mouse or press a key?
Comment 10 Alex Butcher 2009-06-25 05:05:21 EDT
Stefan: it does for me.
Comment 11 Dave Miller 2009-07-14 18:03:37 EDT
Not sure whether this is a different bug or just related but I had the opposite problem with the FC11 gnome screen saver as well as xscreensaver.  Both screen savers did their thing as far as blanking the screen with pretty pictures/animations and locking the system but neither would shut down the monitor to power save mode.  Forcing the monitor off with "vbetool dpms off" worked but isn't exactly convenient.  I ran across advice saying to try "nomodeset" as a kernel parameter and now at lease g-s-s works as expected.  I have re-installed since installing xscreensaver so I am not in a position to see if it now works.

Also, "xset dpms force off" as well as other attempts to use xset to force the screensaver did *NOT* work.  At least xset dpms force off now works (since setting nomodeset).

Finally, as noted above, I re-installed to make sure that none of my earlier flailings had contributed to the problem.  Monitor power save appeared to work correctly with the original FC11 kernel and assorted power management bits.  The lack of power save shut down did not manifest itself until after I used yum update to bring the system to current.

It would be interesting to see if the behavior described in the original bug report "goes away" if the system is started with "nomodeset."

Let me know if this comment should be a separate bug.

Cheers,
Dave
Comment 12 Michael Cronenworth 2009-07-21 00:56:12 EDT
I still see bug this on all four Fedora 11 systems I have (updated as of 7/20). They all use nVidia cards with the proprietary driver, but the driver nor card seem to matter. I have a feeling this is a DeviceKit bug. It will randomly blank on me once (during normal usage, keyboard+mouse) and then not again until I reboot. Could be some counter for DPMS is not being initialized correctly. I'm shooting in the dark though.

Drew O'Brien, do you want to move this bug to gnome-power-manager or DeviceKit? I think one of those two are the culprit.
Comment 13 Drew O'Brien 2009-07-21 03:50:28 EDT
Sorry for the late response. This behavior did affect my system (check the lshw attached for specs) through the Beta->Preview->RC. That system was using an Intel GMA950 (the integrated chip for the 945 Express platform of the desktop.

However, I have since bought a new motherboard and the problem is not replicated in Fedora 11 release on the new system. The new system is similar to the old system, however, running on the newer Intel G31 Express platform (using the Intel GMA 3100 video chip). Using the original Intel driver works comfortably on the new system and I can no longer replicate the bug.

As it is affecting nvidia and intel systems (possibly more who haven't been active in this particular report), it clearly cannot be the fault of the intel driver. Michal Cronenworth, thanks for the comment. This needs to be moved from the intel driver for certain, and I think the logical place to move it would be the gnome-power-manager. The release notes do indicate that there is a common bug (Bug # 501601) that sounds quite similar to this. I am moving it into the gnome-power-manager marker; it may simply merge into the larger bug.
Comment 14 Stefan Ring 2009-07-22 15:52:23 EDT
I cannot confirm that it only happens once and never again until the next reboot. Had it happen twice yesterday. Without restarting X or anything of that kind.
Comment 15 Michael Cronenworth 2009-07-22 16:01:11 EDT
(In reply to comment #14)
> I cannot confirm that it only happens once and never again until the next
> reboot.

Yes, the time period seems to be completely random. Just when you think you have it narrowed down it happens to you.

I've set "Put display to sleep when inactive for:" to "Never" in gnome-power-manager and I haven't gotten a turned off monitor yet. It's only been 24 hours though. I won't consider this option as a workaround until it's been at least a week of solid uptime and at least one reboot. You might try this as well.
Comment 16 Drew O'Brien 2009-07-22 23:46:18 EDT
The bug has been reassigned. My computer was gimped the last few days to running Chrome, which doesn't work properly on Bugzilla. In Gecko, I've reassigned the bug to gnome-power-manager as it is not an Intel, Nvidia, or otherwise problem. The bug I referenced before has a long line of conversation, several workarounds, but still no definitive fix.

Also, this comes from the GNOME blog: http://blogs.gnome.org/hughsie/2009/05/29/gnome-power-manager-unstableness/ 

It is an older article, but does confirm Michael's hunch that it had to do with the switch from HAL to DeviceKit. Fedora is subject to most of these issues which unfortunately won't be resolved until the platform and GNOME mature into stability. Hopefully, the workarounds from the bug and those mentioned in the blog post and comments will give most people a way to fix it. A universal fix still lays a bit in the future, I'm afraid.
Comment 17 Michael Cronenworth 2009-07-29 00:31:36 EDT
I may have stumbled on a way to reproduce the issue.

Screensaver is set to pop art squares. 5 minute idle time. Both checkmarks checked.

gnome-power-manager is set to 10 minutes to put display to sleep.

5 minutes of idle time passed. Screensaver engaged. One minute after screensaver engaged I entered my password and continued to work one to two minutes. One or two minutes after stepping away from my computer I saw my monitor turn off.

I typed on the keyboard -- no picture. Moved my mouse -- picture came back. What I typed was in an IM window that was focused.

I repeated this action twice and was able to reproduce the same effects.
Comment 18 Jason Haar 2009-08-02 22:39:13 EDT
I have a "me too" on this.

I have FC11 installed on a Dell Precision 380 desktop with Nvidia NV43GL video, and a Dell D430 laptop with a Intel 945GM/GMS video, and BOTH have this problem!

I can be literally typing away on the keyboard and the screen will go pitch-black for ~1sec and will then return to normal. Seems to happen 1-2 times a day on both. There are no errors in dmesg, Xorg.0.log nor .xsessions-errors

My Precision workstation was running FC10 last week and it definitely didn't have this problem then - something has been introduced in FC11 that is causing this.

Fully patch FC11, using Gnome. I have screensaver enabled with password protection, after 5 min inactivity. 

This problem is very "minor" in that it clears itself with a click and doesn't appear to cause any issues, but I can tell you it scares the willies out of me every time it happens :-)

Thanks

Jason
Comment 19 Matěj Cepl 2009-08-07 19:12:51 EDT
*** Bug 514271 has been marked as a duplicate of this bug. ***
Comment 20 Richard Hughes 2009-08-20 08:22:42 EDT

*** This bug has been marked as a duplicate of bug 508069 ***
Comment 21 Denys Vlasenko 2009-09-03 14:30:12 EDT
(In reply to comment #18)
> I can be literally typing away on the keyboard and the screen will go
> pitch-black for ~1sec and will then return to normal. Seems to happen 1-2 times
> a day on both. There are no errors in dmesg, Xorg.0.log nor .xsessions-errors

This is a different bug - 501534
Comment 22 Kieran Clancy 2009-10-26 08:20:52 EDT
This is not a dupe of bug 508069; that bug describes the system completely locking up when blanking.

Note You need to log in before you can comment on or make changes to this bug.