Bug 499098 - RFE : firebird module for php
RFE : firebird module for php
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: php-extras (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On: 498790
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 03:56 EDT by Philippe Makowski
Modified: 2009-05-12 13:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 499036
Environment:
Last Closed: 2009-05-12 12:52:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php-extras.spec.patch (3.40 KB, patch)
2009-05-10 03:43 EDT, Remi Collet
no flags Details | Diff

  None (edit)
Description Philippe Makowski 2009-05-05 03:56:28 EDT
+++ This bug was initially created as a clone of Bug #499036 +++

Since Firebird will be packaged into Fedora and EPEL, it would be nice to have  Firebird module for php, as Debian and Mandriva have.

cf https://bugzilla.redhat.com/show_bug.cgi?id=498790

--- Additional comment from fedora@famillecollet.com on 2009-05-05 00:24:28 EDT ---

For EPEL, you need to contact the maintainer of "php-extras" package which provides extension for php working with libraries available in EPEL (we could'nt modify the RH php package)

@joe : any comment about adding this extension to php main package in Fedora ?
Comment 1 Dmitry Butskoy 2009-05-05 08:10:34 EDT
Accroding to https://bugzilla.redhat.com/show_bug.cgi?id=499036#c2 , it is better to ship it in Fedora "common" php package first. Then I'll try to backport this idea to EPEL5's php-extras (if it is possible for that version of php).
Comment 2 Philippe Makowski 2009-05-05 16:30:24 EDT
(In reply to comment #1)
> Accroding to https://bugzilla.redhat.com/show_bug.cgi?id=499036#c2 , it is
> better to ship it in Fedora "common" php package first. Then I'll try to
> backport this idea to EPEL5's php-extras (if it is possible for that version of
> php).  
Thanks, Firebird users will appreciate
now, they make their own build (without trouble in fact)
see for example : http://wiki.firebirdsql.org/wiki/index.php?page=Firebird+Php+on+Centos
Comment 3 Dmitry Butskoy 2009-05-06 08:30:44 EDT
Don't forget to inform here when Firebird will appear in Fedora and EPEL5 .
Comment 4 Philippe Makowski 2009-05-06 09:22:21 EDT
(In reply to comment #3)
> Don't forget to inform here when Firebird will appear in Fedora and EPEL5 .  

yesterday :
firebird-2.1.2.18118.0-6.fc10 successfully moved from dist-f10-updates-candidate into dist-f10-updates by bodhi
firebird-2.1.2.18118.0-6.fc9 successfully moved from dist-f9-updates-candidate into dist-f9-updates by bodhi

and

Fedora EPEL Package Build Report 2009-05-05
Packages built and released for Fedora EPEL testing/5: 11
NEW firebird-2.1.2.18118.0-6.el5 : SQL relational database management system

Packages built and released for Fedora EPEL testing/4: 4
NEW firebird-2.1.2.18118.0-6.el4 : SQL relational database management system
Comment 5 Remi Collet 2009-05-10 03:43:05 EDT
Created attachment 343250 [details]
php-extras.spec.patch

Here is a little patch for php-extras which must do the job.

I also enable pdo_dblib as in latest fedora php-mssql package and disable dbase which is now part of php-common.

Hope this helps.
Comment 6 Dmitry Butskoy 2009-05-12 09:59:18 EDT
Well,

Are you sure that "dbase" is in the current EPEL5's php-common (php version 5.1.6) ?

Is it actually required to combain interbase Nad pdo_firebird together in one subpackage (as well as mssql and pdo_dblib) ? It seems to me that preserving of separate subpackages at least makes the .spec file more clean (ie. subpackage-independent).
Comment 7 Dmitry Butskoy 2009-05-12 10:01:27 EDT
...to combine interbase and pdo_firebird ... :)
Comment 8 Remi Collet 2009-05-12 11:22:50 EDT
> Are you sure that "dbase" is in the current EPEL5's php-common (php version
5.1.6) ?

Yes (php-common-5.1.6-23.2.el5_3, check in CentOS 5.3 RPM and in RHEL SRPM)

I've noticed this when I encounter a conflict during install of RPM build from php-extras spec.

> Is it actually required to combain interbase and pdo_firebird

Not required, but a good idea since there are no additional dependency and package still small.
It is what I'm going to push in rawhide (don't no yet if I'm going to push a 5.2.9 minor update or a 5.3.0 big one)

> as well as mssql and pdo_dblib

Yes, like in Fedora

A lot of sub-packages already provides more than one extension, bundled by theme and by dependencies (and provided by virtual):

php-common : a lot...
php-mysql  : mysql + mysqli + pdo_mysql
php-odbc   : odbc + pdo_odbc
php-pgsql  : pgsql + pdo_pgsql
php-xml    : dom + wddx + xmlreader + xmlwriter + xsl
etc...

This also avoid too much sub-packages.

Regards
Comment 9 Dmitry Butskoy 2009-05-12 12:52:20 EDT
Compiled successfully:
http://buildsys.fedoraproject.org/logs/fedora-5-epel/2275-php-extras-5.1.6-5.el5/

Whether I should do something or it will appear in the repo automatically (as before)?
Comment 10 Remi Collet 2009-05-12 13:07:24 EDT
> it will appear in the repo automatically (as before)?
Yes.

Not yet moved to koji/bodhi.

Note You need to log in before you can comment on or make changes to this bug.