This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 499111 - virt-manager console displayed centered and smaller than guest display
virt-manager console displayed centered and smaller than guest display
Status: CLOSED DUPLICATE of bug 491683
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-05 05:17 EDT by Jens Petersen
Modified: 2009-05-07 04:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 01:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-05 05:17:38 EDT
Description of problem:
In F11 virt-manager the console is always placing the guest display in the middle of the console and the default size is smaller than the guest display.

Version-Release number of selected component (if applicable):
virt-manager-0.7.0-4.fc11

How reproducible:
every time

Steps to Reproduce:
1. install guest
2. enlarge console window
  
Actual results:
1. default size does not show all of guest
2. guest displayed in center not top-left of console display.

Expected results:
1. minimum size console window should show all of guest if possible
2. guest should not be centered but placed in top-left corner of console display to save space on desktop.
Comment 1 Jens Petersen 2009-05-05 05:38:38 EDT
(Problem seems to be new to 0.7.0.)
Comment 2 Jan ONDREJ 2009-05-06 05:45:27 EDT
Same problem on my machine. I am not sure, if it's a problem of virt-manager, may be it's a problem of new display driver in qemu-0.10+.

By default, I can't see right-bottom corner of virtual screen, but there is aprox. 2cm large black box at top and at left side of my virt-manager (virt-viewer) window.

When installing a new Fedora inside virt-manager, my virtual desktop looks to be 1024x768 pixels, but desktop in virtual machine 800x600. Because virtual machine has smaller desktop like exported by VNC, there are black boxes on all sides.

Also using vncviewer localhost:5900 there are same boxes.
Comment 3 Daniel Berrange 2009-05-06 11:44:34 EDT

*** This bug has been marked as a duplicate of bug 491683 ***
Comment 4 Jan ONDREJ 2009-05-06 12:54:42 EDT
Jens, do you have also black boxes on left and top of your virtual desktop? If yes, this is another bug and should be reported to qemu.
If not and this has been fixed for you now, I will open a new bug.
Comment 5 Jens Petersen 2009-05-06 20:23:45 EDT
(In reply to comment #4)
> Jens, do you have also black boxes on left and top of your virtual desktop?

When I enlarge the window yes.

> If yes, this is another bug and should be reported to qemu.

I don't see it when I run directly in qemu though.

> If not and this has been fixed for you now, I will open a new bug.  

Fixed where?  If you have filed another bug please add a pointer here.
Comment 6 Jens Petersen 2009-05-07 01:24:23 EDT

*** This bug has been marked as a duplicate of bug 491683 ***
Comment 7 Jan ONDREJ 2009-05-07 04:44:45 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Jens, do you have also black boxes on left and top of your virtual desktop?
> 
> When I enlarge the window yes.

If only when you enlarge window, then it's another bug.

New bug filled here:

https://bugzilla.redhat.com/show_bug.cgi?id=499563

Note You need to log in before you can comment on or make changes to this bug.