Bug 499147 - Ktorrent crashes when the download speed is changed via the taskbar icon
Ktorrent crashes when the download speed is changed via the taskbar icon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ktorrent (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 08:06 EDT by Daniel Rowe
Modified: 2009-06-30 17:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.2.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 17:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream fix (361 bytes, patch)
2009-05-30 23:19 EDT, Rex Dieter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 188447 None None None Never

  None (edit)
Description Daniel Rowe 2009-05-05 08:06:49 EDT
Description of problem:

Ktorrent crashes when the download speed is changed via the taskbar icon WITH the ktorrent window open. Adjusting the upload speed is fine. System is all up to date and working fine.

Version-Release number of selected component (if applicable):

ktorrent-3.2.1-1.fc10.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Run ktorrent
2. Make sure ktorrent window is open
3. Adjust the download speed with the ktorrent window open
  
Actual results:

Crash:

0x00000031afca7f81 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7feb94f61810 (LWP 3968))]

Thread 3 (Thread 0x7feb8bfb9950 (LWP 3970)):
#0  0x00000031b080b58d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x000000311d05a115 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x000000311d05a27e in QThread::msleep () from /usr/lib64/libQtCore.so.4
#3  0x0000003d6da4c735 in ?? () from /usr/lib64/libbtcore.so.10
#4  0x0000003d6da4cf49 in ?? () from /usr/lib64/libbtcore.so.10
#5  0x000000311d05a6d2 in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00000031b08073da in start_thread () from /lib64/libpthread.so.0
#7  0x00000031afce62bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7feb7d2b0950 (LWP 3971)):
#0  0x00000031b080b309 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x000000311d05b6b9 in QWaitCondition::wait () from /usr/lib64/libQtCore.so.4
#2  0x0000003d6da4be04 in ?? () from /usr/lib64/libbtcore.so.10
#3  0x0000003d6da4cf49 in ?? () from /usr/lib64/libbtcore.so.10
#4  0x000000311d05a6d2 in ?? () from /usr/lib64/libQtCore.so.4
#5  0x00000031b08073da in start_thread () from /lib64/libpthread.so.0
#6  0x00000031afce62bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7feb94f61810 (LWP 3968)):
#0  0x00000031afca7f81 in nanosleep () from /lib64/libc.so.6
#1  0x00000031afca7da7 in sleep () from /lib64/libc.so.6
#2  0x0000003d6b46918f in ?? () from /usr/lib64/libkdeui.so.5
#3  0x0000003d6b469aea in KCrash::defaultCrashHandler () from /usr/lib64/libkdeui.so.5
#4  <signal handler called>
#5  0x000000311e5b4c2e in QMenu::findIdForAction () from /usr/lib64/libQtGui.so.4
#6  0x000000311e5b613b in ?? () from /usr/lib64/libQtGui.so.4
#7  0x000000311e5bc26e in ?? () from /usr/lib64/libQtGui.so.4
#8  0x0000003d6b4d2221 in KMenu::mouseReleaseEvent () from /usr/lib64/libkdeui.so.5
#9  0x000000311e1df84f in QWidget::event () from /usr/lib64/libQtGui.so.4
#10 0x000000311e5bea2b in QMenu::event () from /usr/lib64/libQtGui.so.4
#11 0x000000311e18e73d in QApplicationPrivate::notify_helper () from /usr/lib64/libQtGui.so.4
#12 0x000000311e19708a in QApplication::notify () from /usr/lib64/libQtGui.so.4
#13 0x0000003d6b406c7b in KApplication::notify () from /usr/lib64/libkdeui.so.5
#14 0x000000311d14360c in QCoreApplication::notifyInternal () from /usr/lib64/libQtCore.so.4
#15 0x000000311e1962d8 in QApplicationPrivate::sendMouseEvent () from /usr/lib64/libQtGui.so.4
#16 0x000000311e1ffd44 in ?? () from /usr/lib64/libQtGui.so.4
#17 0x000000311e1fe7f8 in QApplication::x11ProcessEvent () from /usr/lib64/libQtGui.so.4
#18 0x000000311e225bb4 in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00000031194377bb in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x000000311943af8d in ?? () from /lib64/libglib-2.0.so.0
#21 0x000000311943b14b in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x000000311d16cd1f in QEventDispatcherGlib::processEvents () from /usr/lib64/libQtCore.so.4
#23 0x000000311e22533f in ?? () from /usr/lib64/libQtGui.so.4
#24 0x000000311d141eb2 in QEventLoop::processEvents () from /usr/lib64/libQtCore.so.4
#25 0x000000311d14227d in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#26 0x000000311d144544 in QCoreApplication::exec () from /usr/lib64/libQtCore.so.4
#27 0x0000000000421c03 in _start ()


Expected results:

Works with no crash.

Additional info:

Seems to be since last update.
Comment 1 Daniel Rowe 2009-05-05 08:30:28 EDT
Looks like this is a known upstream bug:

https://bugs.kde.org/show_bug.cgi?id=188447

http://ktorrent.org/forum/viewtopic.php?t=3040

Any chance of getting the fedora version patched?
Comment 2 Rex Dieter 2009-05-05 08:58:17 EDT
triaged.
Comment 3 Steven M. Parrish 2009-05-30 22:57:55 EDT
rex, do you want to backport this patch or just wait for the next release?
Comment 4 Rex Dieter 2009-05-30 23:18:18 EDT
Patching looks easy enough.
Comment 5 Rex Dieter 2009-05-30 23:19:05 EDT
Created attachment 345996 [details]
upstream fix
Comment 6 Rex Dieter 2009-05-30 23:23:27 EDT
Heh, looks like I committed the fix awhile back,

%changelog
* Tue May 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.2.1-3
- crash adjusting speed from systray (kdebug#188447, rhbz#499147)

But failed to issue an update.  Will do.
Comment 7 Fedora Update System 2009-05-30 23:26:26 EDT
ktorrent-3.2.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ktorrent-3.2.1-3.fc11
Comment 8 Fedora Update System 2009-05-30 23:38:07 EDT
ktorrent-3.2.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ktorrent-3.2.1-3.fc10
Comment 9 Fedora Update System 2009-05-30 23:49:09 EDT
ktorrent-3.2.1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ktorrent-3.2.1-3.fc9
Comment 10 Daniel Rowe 2009-05-31 00:17:37 EDT
Confirmed issue fixed you updated package (ktorrent-3.2.1-3.fc10.x86_64.rpm). Thanks.
Comment 11 Fedora Update System 2009-06-02 10:15:18 EDT
ktorrent-3.2.1-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-5712
Comment 12 Fedora Update System 2009-06-02 10:27:43 EDT
ktorrent-3.2.1-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5758
Comment 13 Fedora Update System 2009-06-02 10:31:49 EDT
ktorrent-3.2.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5779
Comment 14 Fedora Update System 2009-06-03 15:28:41 EDT
ktorrent-3.2.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ktorrent-3.2.2-2.fc11
Comment 15 Fedora Update System 2009-06-03 15:28:44 EDT
ktorrent-3.2.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ktorrent-3.2.2-2.fc10
Comment 16 Fedora Update System 2009-06-03 15:28:46 EDT
ktorrent-3.2.2-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ktorrent-3.2.2-2.fc9
Comment 17 Fedora Update System 2009-06-15 21:46:10 EDT
ktorrent-3.2.2-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6157
Comment 18 Fedora Update System 2009-06-15 21:52:45 EDT
ktorrent-3.2.2-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-6210
Comment 19 Fedora Update System 2009-06-15 22:46:18 EDT
ktorrent-3.2.2-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6491
Comment 20 Fedora Update System 2009-06-30 17:21:29 EDT
ktorrent-3.2.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2009-06-30 17:33:03 EDT
ktorrent-3.2.2-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2009-06-30 17:39:58 EDT
ktorrent-3.2.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.