Bug 499161 - expose Spacewalk behavior via a CLI
expose Spacewalk behavior via a CLI
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
0.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-05-05 09:43 EDT by Jesus M. Rodriguez
Modified: 2009-09-10 08:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesus M. Rodriguez 2009-05-05 09:43:52 EDT
The Spacewalk API has been enhanced with each release of Spacewalk:
https://fedorahosted.org/spacewalk/wiki/ApiAdditions

What would be great is to have a CLI to interact with the Spacewalk server something along the lines of:

spacewalk user create --login=foo@redhat.com
spacewalk channel create --name="RHEL 5 i386" --arch=i386 --label=rhel5-i386
spacewalk kickstart create --name=rhel5-i386 --channel=rhel5-i386
spacewalk activationkey create --name=rhel5-i386 --channel=rhel5-i386

and so on .. would be immensely useful.  Just because our GUI is large 
and has many many different things to manage that doesn't mean there are 
simple entry points to all the common objects in Satellite.

The above could just be an interface to our existing XMLRPC API, all the 
above and more is available to be called to without our GUI.  The only 
thing we are lacking is an implementation of the actual CLI bits.
Comment 1 Miroslav Suchý 2009-07-22 05:36:45 EDT
Done in commit:
fe7fd7a22df8d7055b25aae5f82c742c88b5f1d6
The new script is call spacewalk-api and is in package spacewalk-utils
Comment 2 Miroslav Suchý 2009-09-10 08:00:53 EDT
Spacewalk 0.6 released.

Note You need to log in before you can comment on or make changes to this bug.