Bug 49918 - apmd resumes pcmcia, then network, hotplug expects network first
apmd resumes pcmcia, then network, hotplug expects network first
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 01:08 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 18:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-25 01:08:37 EDT
The apmd-script included in apmd-3.0final does the following on resume:

cardctl resume/insert
service networking start

Unfortunately, if one of your pcmcia cards is a PCI-merged networking card
such as the 3c575_cb, hotplug does the following upon seeing the card
resumed...

if networking is started, configure the new interface

Thus, because apmd reenables pcmcia before networking, a pcmcia network
adapter won't be configured by hotplug.             

One easy sollution, is that if the pcmcia network adapter is always in the
system, you can enable ONBOOT for the interface, and thus the networking
script will enable it for you.  In my case (frequently switching between
LAN and WAN cards), that isn't an option.
Comment 1 Trond Eivind Glomsrxd 2001-07-25 18:37:47 EDT
Sounds like an apmd problem...
Comment 2 Bernhard Rosenkraenzer 2002-02-26 12:27:03 EST
 Fixed in 3.0.2-6

Note You need to log in before you can comment on or make changes to this bug.