Bug 499194 - anaconda fails to install grub in KVM guest
anaconda fails to install grub in KVM guest
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-05-05 11:10 EDT by Mark McLoughlin
Modified: 2009-05-05 13:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 12:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-05-05 11:10:43 EDT
Using 2009-05-04 rawhide

I've installed a 64 bit guest using virtio, a 32 bit guest using virtio and a 64 bit guest using IDE, and each time grub wasn't installed and boot failed after install

Looking at program.log:

---
Running... ['/sbin/grub', '--batch', '--no-floppy', '--device-map=/boot/grub/device.map']


    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> root (hd0,0)

Error 21: Selected disk does not exist
grub> install --stage2=/boot/grub/stage2 /grub/stage1 d (hd0) /grub/stage2 p (hd0,0)/grub/grub.conf

Error 12: Invalid device requested
---

/mnt/sysimage/boot/grub/device.map contains "(hd0) /dev/sda"

Interestingly, if I run:

  grub --device-map=/mnt/sysimage/boot/grub/device.map

if I run:

  chroot /mnt/sysimage grub --device-map=/boot/grub/device.map

then it doesn't work; looks like an empty /mnt/sysimage/dev is the problem?
Comment 1 Mark McLoughlin 2009-05-05 11:12:28 EDT
Ah, I see there's a newer anaconda in today's rawhide - I'll try again
Comment 2 Mark McLoughlin 2009-05-05 12:03:03 EDT
Okay, seems to be fixed in today's rawhide.
Comment 3 Denise Dumas 2009-05-05 13:10:03 EDT
Great, thanks for validating.

Note You need to log in before you can comment on or make changes to this bug.