Bug 499225 - F11 Preview: Kickstart install crashes when installing over an encrypted partition
F11 Preview: Kickstart install crashes when installing over an encrypted part...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 12:42 EDT by ajs
Modified: 2009-09-04 13:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 13:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file that causes a ValueError to be raised (1.23 KB, text/plain)
2009-05-05 12:42 EDT, ajs
no flags Details
Photo of the traceback (73.70 KB, image/jpeg)
2009-05-05 13:10 EDT, ajs
no flags Details

  None (edit)
Description ajs 2009-05-05 12:42:35 EDT
Created attachment 342491 [details]
Kickstart file that causes a ValueError to be raised

Description of problem:
When doing a kickstart install on an encrypted partition, kickstart raises a ValueError exception with the message "device must be a fully qualified path"

Version-Release number of selected component (if applicable):
11.5.0.47


How reproducible:
Always

Steps to Reproduce:
1. Install F11-Preview and encrypt the root partition
2. Edit the generated anaconda-ks.cfg, adding partitioning commands

   # == Partitions
   clearpart --linux --drives=sda
   part /boot --fstype ext3 --size=200 --ondisk=sda
   part pv.41 --encrypted --size=0 --grow --ondisk=sda  --passphrase="test"
   volgroup vg_fleuret --pesize=32768 pv.41
   logvol / --fstype ext4 --name=lv_root --vgname=vg_fleuret --size=1024 --grow
   logvol swap --fstype swap --name=lv_swap --vgname=vg_fleuret --size=1936 --grow --maxsize=3872


3. Copy the anaconda-ks.cfg to a USB stick (see attachment)
4. Reboot from the install CD
5. Edit the boot arguments, adding e.g. 'ks=hd:sdb1/anaconda-ks.cfg'
  
Actual results:
ValueError exception with the message "device must be a fully qualified path"


Expected results:
Successful installation

Additional info:
Comment 1 ajs 2009-05-05 12:55:02 EDT
In the 'Steps to Reproduce:' section, add

6. Enter password for encrypted partition

Also, adding
%traceback
umount /dev/sdb1
mount -o rw /dev/sdb1 /tmp/mnt
cp /tmp/anacdump.txt /tmp/mnt

does not result in anacdump.txt being copied to the USB stick
Comment 2 ajs 2009-05-05 13:10:28 EDT
Created attachment 342496 [details]
Photo of the traceback

Here is a picture of the traceback sing the %traceback script is not working for me
Comment 3 ajs 2009-05-05 13:15:43 EDT
While I filled out this report by installing F11 preview and used the generated kickstart file, I did this to make sure that there were not changes in the kickstart syntax that I was unaware of.  The error first showed up when I tried to reinstall over an F10 installation.
Comment 4 Bug Zapper 2009-06-09 11:11:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chris Lumens 2009-06-09 11:34:31 EDT
This looks like a legitimate bug, but we could really use the anacdump.txt file to figure out what request.path looks like.  Can you add some debugging to figure out what might be going wrong with the %traceback script and attach the file if at all possible?
Comment 6 ajs 2009-06-09 12:09:22 EDT
I assume that you want me to try with the released version of F11.  I will download it now.
Comment 7 Chris Lumens 2009-06-09 12:48:48 EDT
That'd be great, thanks.
Comment 8 ajs 2009-06-25 13:26:44 EDT
I'm in the middle of a design review: I have not forgotten.

I tried once and got a different error and will look at it when I have a few minutes of time.

Note You need to log in before you can comment on or make changes to this bug.