Bug 49928 - gcc Segmentation fault by all attempts to compile something.
gcc Segmentation fault by all attempts to compile something.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 10:10 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 10:10:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-25 10:10:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
My compiler crashes with "Internal error: Segmentation fault." when 
compiling any product.


How reproducible:
Always

Steps to Reproduce:
1.It crashes everytime when I try to compile large (for example > 500Kb) 
amounts of source with 'make' program.
2.
3.
	

Actual Results:  It crashes and gives error message. The following is 
copied&pasted from my Linux console during my 6th attempt to compile the 
kernel:

gcc -D__KERNEL__ -I/root/linux/include -Wall -Wstrict-prototypes -Wno-
trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -
mpreferred-stack-boundary=2 -march=i686  -DUTS_MACHINE='"i386"' -c -o 
init/version.o init/version.c
make CFLAGS="-D__KERNEL__ -I/root/linux/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -
pipe -mpreferred-stack-boundary=2 -march=i686 " -C  kernel
make[1]: Entering directory `/root/linux/kernel'
make all_targets
make[2]: Entering directory `/root/linux/kernel'
gcc -D__KERNEL__ -I/root/linux/include -Wall -Wstrict-prototypes -Wno-
trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -
mpreferred-stack-boundary=2 -march=i686    -DEXPORT_SYMTAB -c signal.c
signal.c: In function `signals_init':
signal.c:45: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [signal.o] Error 2
make[2]: Leaving directory `/root/linux/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/root/linux/kernel'
make: *** [_dir_kernel] Error 2

This repeats when I try to compile samba, ssh etc. Every time the file 
which the error has occured in is changing. So the problem isn't in a 
specific file/source and probably doesn't depend on the source.

Expected Results:  Programs must compile properly but they don't.

Additional info:

I'm using RH 7.1 (Seawolf) with 32 MB RAM, CPU type 686, with gcc version 
2.96-81. The problem exists even with 2.96-85. All other binaries and libs 
are installed by default from RH 7.1 disks.
Comment 1 Jakub Jelinek 2001-07-25 10:15:47 EDT
This is typical symptom of hardware problems, be it defective RAM
(run some good memory checker), defective CPU or mainboard.
It might as well be bad BIOS setting related to cache setting, overclocking
etc.
Compiler bugs are reproducible with the same options on the same input.

Note You need to log in before you can comment on or make changes to this bug.