Bug 499286 - Files on FTP >4GB reported as 4GB
Files on FTP >4GB reported as 4GB
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 19:12 EDT by Henry Lajoie
Modified: 2015-03-03 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.0.3-8.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 00:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henry Lajoie 2009-05-05 19:12:14 EDT
Description of problem:
FTP locations mounted using GVFS will report file sizes incorrectly for files greater than 4GB, they are reported as 4GB.  However, downloading the files will retrieve the whole file and uploading files will upload the whole file correctly.

Version-Release number of selected component (if applicable):
gvfs-1.0.3-7.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Create a file >4GB on an FTP server
2. Access FTP server via GVFS
  
Actual results:
(for files over 4GB) File size reported as 4Gb

Expected results:
File size reports as correct size (in my test case, 11GB)

Additional info:
Download times will be calculated incorrectly because of this
The text progress of X downloaded out of 4GB will adjust the 4GB value when X goes above 4GB
Using the command 'ftp', size of the files are reported correctly
Comment 1 Tomáš Bžatek 2009-05-06 12:52:01 EDT
Can you please test new packages from
http://koji.fedoraproject.org/koji/taskinfo?taskID=1338799

I've fixed the issue, only 32bit systems were affected.
Comment 2 Fedora Update System 2009-05-07 07:59:21 EDT
gvfs-1.0.3-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-8.fc10
Comment 3 Fedora Update System 2009-05-09 00:23:02 EDT
gvfs-1.0.3-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.