Bug 499320 - OpenOffice.org Impress crashes when opening up a specific .pps file
OpenOffice.org Impress crashes when opening up a specific .pps file
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 02:24 EDT by Nik Lam
Modified: 2009-05-19 11:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 11:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Powerpoint file which causes RHEL5 OpenOffice.org to crash (3.60 MB, application/vnd.ms-powerpoint)
2009-05-06 02:24 EDT, Nik Lam
no flags Details
mapped stack (8.44 KB, text/plain)
2009-05-14 07:42 EDT, David Tardon
no flags Details

  None (edit)
Description Nik Lam 2009-05-06 02:24:12 EDT
Created attachment 342595 [details]
Powerpoint file which causes RHEL5 OpenOffice.org to crash

Description of problem: When opening up the a PPS file that I'll try to attach with this bugreport (if it's not too big), I get a "OOo has crashed!" dialogue box with the following contents:




(I)    x.org loaded video driver of...
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-44.el5-x86_64 libgcj-4.1.2-44.el5-i386
(V)    kernel is: Linux 2.6.18-128.1.6.el5xen #1 SMP Tue Mar 24 12:28:27 EDT 2009 x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.10.el5-x86_64
(VII)  depth of root window:    16 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x00000036dba36b44: 0x00000000001ebb68: /usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x36b44
0x00000036dba3773a: 0x00000000001ebb68: /usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x3773a
0x00000031ce40e4c0: 0x0000000000015da8: /lib64/libpthread.so.0 + 0xe4c0
0x00000036dba2d9b0: 0x00000000001ebb68: /usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x2d9b0 (osl_incrementInterlockedCount + 0x20)
0x0000003a49e162da: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4162da
0x0000003a49bc52ce: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x1c52ce
0x0000003a49bbb6f7: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x1bb6f7
0x0000003a49bbc16c: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x1bc16c
0x0000003a49ec170f: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4c170f
0x0000003a49ec1c96: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4c1c96
0x0000003a49ec3709: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4c3709
0x0000003a49eab934: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4ab934
0x0000003a49eac162: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4ac162
0x0000003a49eb6c1a: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4b6c1a
0x0000003a49eb7871: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4b7871
0x0000003a49eacda4: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4acda4
0x0000003a42ea69e1: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0x2a69e1
0x00002aaaae791def: 0x0000000000081dd0: /usr/lib64/openoffice.org/program/libvclplug_gen680lx.so + 0x57def (SalDisplay::DispatchInternalEvent() + 0xbf)
0x00002aaaae0c8089: 0x000000000004ffe8: /usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x18089
0x0000003a4022cdb4: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x2cdb4 (g_main_context_dispatch + 0x1b4)
0x0000003a4022fc0d: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x2fc0d
0x0000003a4023011e: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x3011e (g_main_context_iteration + 0x6e)
0x00002aaaae0c9b19: 0x000000000004ffe8: /usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x19b19
0x0000003a42ccebf3: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0xcebf3 (Application::Reschedule(bool) + 0x33)
0x0000003a49edd4bf: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x4dd4bf
0x0000003a49c1559a: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x21559a
0x0000003a49bfb7f8: 0x00000000005d8a98: /usr/lib64/openoffice.org/program/libsd680lx.so + 0x1fb7f8
0x0000003a46662678: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x262678
0x0000003a4666fb6c: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x26fb6c (SfxTopViewFrame::SfxTopViewFrame(SfxFrame*, SfxObjectShell*, unsigned short) + 0x1fc)
0x0000003a46672394: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x272394 (SfxTopFrame::InsertDocument(SfxObjectShell*) + 0x664)
0x0000003a465cd56f: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x1cd56f
0x0000003a466722b3: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x2722b3 (SfxTopFrame::InsertDocument(SfxObjectShell*) + 0x583)
0x0000003a4664e535: 0x00000000003f5e88: /usr/lib64/openoffice.org/program/libsfx680lx.so + 0x24e535
0x0000003a46da658f: 0x00000000002f4458: /usr/lib64/openoffice.org/program/libfwk680lx.so + 0x1a658f
0x0000003a46da7f90: 0x00000000002f4458: /usr/lib64/openoffice.org/program/libfwk680lx.so + 0x1a7f90
0x0000003a46da81d8: 0x00000000002f4458: /usr/lib64/openoffice.org/program/libfwk680lx.so + 0x1a81d8
0x0000003a46c6cfbf: 0x00000000002f4458: /usr/lib64/openoffice.org/program/libfwk680lx.so + 0x6cfbf
0x0000003a47a41a56: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x41a56 (desktop::DispatchWatcher::executeDispatchRequests(std::vector<desktop::DispatchWatcher::DispatchRequest, std::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0x1616)
0x0000003a47a35b73: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x35b73 (desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&) + 0x143)
0x0000003a47a30a33: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x30a33 (desktop::Desktop::OpenClients() + 0x11d3)
0x0000003a47a3206a: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x3206a (desktop::Desktop::OpenClients_Impl(void*) + 0x3a)
0x0000003a42ea69e1: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0x2a69e1
0x00002aaaae791def: 0x0000000000081dd0: /usr/lib64/openoffice.org/program/libvclplug_gen680lx.so + 0x57def (SalDisplay::DispatchInternalEvent() + 0xbf)
0x00002aaaae0c8089: 0x000000000004ffe8: /usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x18089
0x0000003a4022cdb4: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x2cdb4 (g_main_context_dispatch + 0x1b4)
0x0000003a4022fc0d: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x2fc0d
0x0000003a4023011e: 0x000000000009c6f8: /lib64/libglib-2.0.so.0 + 0x3011e (g_main_context_iteration + 0x6e)
0x00002aaaae0c9b19: 0x000000000004ffe8: /usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x19b19
0x0000003a42cceb7e: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0xceb7e (Application::Yield(bool) + 0x3e)
0x0000003a42ccec57: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0xcec57 (Application::Execute() + 0x27)
0x0000003a47a2cec3: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x2cec3 (desktop::Desktop::Main() + 0x13a3)
0x0000003a42cd4354: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd4354
0x0000003a42cd4445: 0x00000000003aefe8: /usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd4445 (SVMain() + 0x25)
0x0000003a47a1f4ce: 0x000000000005b478: /usr/lib64/openoffice.org/program/libsoffice.so + 0x1f4ce (main + 0xae)
0x00000031cd81d974: 0x000000000014fb60: /lib64/libc.so.6 + 0x1d974 (__libc_start_main + 0xf4)
0x0000000000400619: 0x0000000000000870: /usr/lib64/openoffice.org/program/simpress.bin + 0x619 (main + 0x49)
...end stackreport details ...
...start sample ldd details ...
	libuno_sal.so.3 => /usr/lib64/openoffice.org/program/libuno_sal.so.3 (0x00002ad3f01fe000)
	libuno_salhelpergcc3.so.3 => /usr/lib64/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x00002ad3f05f5000)
	libstore.so.3 => /usr/lib64/openoffice.org/program/libstore.so.3 (0x00002ad3f07f9000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00002ad3f0a24000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00002ad3f0c28000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002ad3f0e43000)
	libm.so.6 => /lib64/libm.so.6 (0x00002ad3f1144000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002ad3f13c7000)
	libc.so.6 => /lib64/libc.so.6 (0x00002ad3f15d5000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002ad3f192c000)
	/lib64/ld-linux-x86-64.so.2 (0x00000031cc800000)
...end sample ldd details ...


Version-Release number of selected component (if applicable):
openoffice.org-impress-2.3.0-6.10.el5

How reproducible:
Always


Steps to Reproduce:
1. Double click on file icon
2. OpenOffice Impress tries to launch and crashes
3. Dialogue box with crash dump appears.
  
Actual results:
Crash.

Expected results:
Launch of Impress

Additional info:

The file opens OK on Fedora 10 (openoffice.org-impress-3.0.1-15.3.fc10.x86_64)
Comment 1 David Tardon 2009-05-09 11:09:38 EDT
Hmm, I cannot reproduce the crash. Let's hope the backtrace will reveal something....
Comment 2 Matěj Cepl 2009-05-12 17:59:27 EDT
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 5 David Tardon 2009-05-14 07:42:35 EDT
Created attachment 343949 [details]
mapped stack
Comment 6 David Tardon 2009-05-14 07:44:43 EDT
As follows from the stacktrace, the problem is in impress UI--it fails during redrawing of the Normal View tab in the central panel. The redrawing itself is asynchronous event, triggered by timer. But that doesn't explain the crash :( I'm completely mystified by the first four frames of the stack--perhaps a chancy timing issue causing a memory corruption in the main thread?

dtardon->nik: Does Impress crash always on opening of that file or did it happened just once? If it's always, does Impress crash on opening of different presentation or creating of empty one? Does it crash on opening the file through File->Open dialog? Do you have Quickstarter enabled (Tools->Options...->OpenOffice.org->Memory)? And last but not least: does it crash after you moved away your configuration ($HOME/.openoffice.org2.0)?
Comment 8 David Tardon 2009-05-14 10:28:28 EDT
dtardon->nik: Just two more questions: what openoffice.org packages have you installed (run " rpm -qa | grep -F openoffice.org " in terminal)? Have you any extensions installed (run " /usr/lib64/openoffice.org/program/unopkg list " and " /usr/lib64/openoffice.org/program/unopkg list --shared " in terminal)?
Comment 9 Nik Lam 2009-05-18 02:27:14 EDT
Hi David,

Now that I've come back to this and tried the file again, I can't get it to cause a crash, but it was definitely occurring consistently when I first reported the bug. I must admit though, I didn't reboot the system at the time, and I have since applied some rpm updates.

I'm pretty sure I tried opening the file from within OO.org using File->Open and it crashed then too.

For what it's worth, now that I can't make it crash:

[nik@chipolata ~]$ rpm -qa | grep -F openoffice.org
openoffice.org-graphicfilter-2.3.0-6.10.el5
openoffice.org-impress-2.3.0-6.10.el5
openoffice.org-math-2.3.0-6.10.el5
openoffice.org-writer-2.3.0-6.10.el5
openoffice.org-calc-2.3.0-6.10.el5
openoffice.org-xsltfilter-2.3.0-6.10.el5
openoffice.org-core-2.3.0-6.10.el5
openoffice.org-draw-2.3.0-6.10.el5
[nik@chipolata ~]$ /usr/lib64/openoffice.org/program/unopkg list
all deployed user packages:
<none>
[nik@chipolata ~]$ /usr/lib64/openoffice.org/program/unopkg list --shared
all deployed shared packages:
<none>
[nik@chipolata ~]$ rpm -qa --last | head
poppler-0.5.4-4.4.el5_3.9                     Thu 14 May 2009 06:32:19 AM EST
poppler-0.5.4-4.4.el5_3.9                     Thu 14 May 2009 06:32:17 AM EST
audit-libs-python-1.7.7-6.el5_3.3             Sun 10 May 2009 04:27:22 PM EST
audit-1.7.7-6.el5_3.3                         Sun 10 May 2009 04:27:22 PM EST
pango-1.14.9-5.el5_3                          Sun 10 May 2009 04:27:21 PM EST
audit-libs-1.7.7-6.el5_3.3                    Sun 10 May 2009 04:27:21 PM EST
kernel-xen-2.6.18-128.1.10.el5                Sun 10 May 2009 04:27:06 PM EST
jabberpy-0.5-0.17.el5                         Sun 10 May 2009 04:27:03 PM EST
kernel-2.6.18-128.1.10.el5                    Sun 10 May 2009 04:26:46 PM EST
acpid-1.0.4-7.el5_3.1                         Sun 10 May 2009 04:26:44 PM EST
[nik@chipolata ~]$ 


Let me know if there's anything else you'd like me to try.

Nik
Comment 10 Matěj Cepl 2009-05-18 04:44:26 EDT
OK, so if you are able to reproduce this in some reliable way, let us know and we can try to take a look again. Otherwise, if we won't get information on how to reproduce it here in 30 days, we will close this as INSUFFICIENT_DATA.

Thank you for reporting the issue.
Comment 11 Caolan McNamara 2009-05-19 11:43:28 EDT
Yeah, got around to looking into this. valgrind doesn't report anything relevant that would explain it. I don't think it's really related to the .pps, but something else, such as restoring some stored locations of toolbars/outline view or some UI element. Can't reproduce either.

Note You need to log in before you can comment on or make changes to this bug.