Bug 499354 - ibus does not detect when engines have been removed
ibus does not detect when engines have been removed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-05-06 06:31 EDT by Ignacio Vazquez-Abrams
Modified: 2009-05-06 23:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 23:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2009-05-06 06:31:13 EDT
ibus-0.1.1.20090203-1.fc10.x86_64

The various m17n engines were showing up in the ibus engine tab. Since I had no need to use them, I closed the dialog box and removed m17n\* via yum. I then opened up the ibus preferences box and they were still showing on the engines tab. I would have expected the entries to be removed once the engines had been removed. Fortunately switching to SCIM and back to ibus cleared this up.
Comment 1 Peng Huang 2009-05-06 23:08:34 EDT
You need restart ibus or relogin your desktop. And then the new ibus processes will rescan all engines. Actually, it is not a bug. It is a limit.

Note You need to log in before you can comment on or make changes to this bug.