Bug 499379 - Pidgin crashing
Pidgin crashing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pidgin (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Warren Togami
desktop-bugs@redhat.com
:
Depends On: 492014
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 09:17 EDT by Mauricio Teixeira
Modified: 2015-08-17 09:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Teixeira 2009-05-06 09:17:44 EDT
Same problem reported in BZ#492014 for Fedora, also happens in RHEL 5.3. Will get a stack trace soon.
Comment 1 Mauricio Teixeira 2009-05-25 07:08:38 EDT
I found out this is related to memory leak when trying to display users with unicode characters in their display names on MSN.

If I remove such users, pidgin never crashes again.

If I run pidgin from inside Valdring, I get _tons_ of memory leak warnings, it runs very slow, but does not crash.

(08:05:03) msn: S: SB 001: JOI gilvanfalcaojr@hotmail.com Gilvan%20Falcão 2788999228
(08:05:03) msn: Processing queue
(08:05:03) msn: Sending message
(08:05:03) msn: C: SB 001: MSG 3 D 828
(08:05:03) msn: switchboard send msg..
(08:05:03) msn: C: SB 001: MSG 4 U 98
(08:05:03) msn: S: SB 001: ACK 3
(08:05:03) msn: S: SB 001: MSG gilvanfalcaojr@hiddenemail.com Gilvan%20Falcão 145
(08:05:04) msn: S: SB 001: MSG gilvanfalcaojr@hiddenemail.com Gilvan%20Falcão 532
(08:05:04) GLib: gmem.c:136: failed to allocate 2264989697 bytes

warning: the debug information found in "/usr/lib/debug//lib/libglib-2.0.so.0.1800.4.debug" does not match "/lib/libglib-2.0.so.0" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libglib-2.0.so.0.1800.4.debug" does not match "/lib/libglib-2.0.so.0" (CRC mismatch).

dns[10793]: nobody needs me... =(
Comment 2 RHEL Product and Program Management 2014-03-07 08:57:05 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:23:57 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 4 Mauricio Teixeira 2015-08-17 09:00:18 EDT
Bug is closed, removing NEEDINFO flag.

Note You need to log in before you can comment on or make changes to this bug.